Commit d2c98c93 authored by Denis Laxalde's avatar Denis Laxalde Committed by Philippe Pepiot
Browse files

Target postgresql 9.6

We'll need this from cubicweb-saem_ref >= 0.18.0 and better upgrade now
before getting in production.
parent ca095be0
......@@ -35,7 +35,7 @@ Cubicweb config files are located in ``~saemref/etc/cubicweb.d/saemref`` and
``CW_MODE=user``.
The state require the installation of `epel-formula`_ and `postgres-formula`_
with version 9.4 (see ``pillar.example``).
with version 9.6 (see ``pillar.example``).
``saemref.config``
------------------
......
......@@ -4,6 +4,7 @@
{% if grains['os_family'] == 'RedHat' %}
include:
- postgres.upstream
- postgres.client
epel-release:
pkg.installed
......@@ -31,7 +32,6 @@ cube-packages:
- libgecode-dev
- g++
{% else %}{# RedHat #}
- postgresql94
- graphviz-gd
- python-devel
- gecode-devel
......
......@@ -41,4 +41,4 @@ saemref:
pass: admin
postgres:
version: 9.4
version: 9.6
FROM postgres:9.4
FROM postgres:9.6
RUN apt-get -qqy update && apt-get -qqy install postgresql-plpython-9.4
RUN apt-get -qqy update && apt-get -qqy install postgresql-plpython-9.6
......@@ -18,13 +18,13 @@ wait_saemref_started = pytest.mark.usefixtures("_wait_saemref_started")
def test_package_postgresclient(host):
if host.system_info.distribution == "centos":
name = "postgresql94"
name = "postgresql96"
else: # Debian
name = "postgresql-client"
pkg = host.package(name)
assert pkg.is_installed
assert pkg.version.startswith("9.4")
assert pkg.version.startswith("9.6")
def test_pip_packages(host):
......@@ -99,7 +99,7 @@ def test_pillars(host):
}
}
assert pillars == {
'postgres': {'version': 9.4},
'postgres': {'version': 9.6},
'saemref': {'lookup': expected}
}
host.salt("state.sls", "test_pillar")
......
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment