Commit 8df8d9fc authored by Bat's avatar Bat

Fixed CI: poulp now uses itself to be compiled and install dependencies

parent 9471939a
image: fedora:24
before_script:
- dnf install wget unzip vala vala-devel json-glib-devel libgee-devel make gcc git -y
- dnf install wget -y
- wget https://bintray.com/bat41/rpm/rpm -O bintray-bat41-rpm.repo
- mv bintray-bat41-rpm.repo /etc/yum.repos.d/
- dnf install poulp wget unzip vala vala-devel json-glib-devel libgee-devel make gcc git -y
- export POULP_VERSION=$(git describe --tags --abbrev=0)
- >
if [ -z "$POULP_VERSION" ]; then
export POULP_VERSION=$(git rev-parse --short HEAD)
fi
- echo "$POULP_VERSION"
- poulp install
stages:
- build
......@@ -18,18 +22,15 @@ stages:
build:
stage: build
script:
- make build
- poulp build
artifacts:
paths:
- build/*
linter:
stage: test
before_script:
- dnf install make ruby wget -y
- wget https://framagit.org/valse/vala-style/raw/master/style.rb
script:
- make lint
- poulp lint
rpm:
stage: package
......
......@@ -20,7 +20,7 @@ function create_package () {
--replaces poulp \
--depends vala --depends libgee \
--license "LGPLv3" \
--url CI_PROJECT_URL \
--url $CI_PROJECT_URL \
--description "Vala projects and packages manager" \
-a $(uname -m) \
-C ./build/ \
......
......@@ -19,7 +19,7 @@ function create_package () {
--replaces poulp \
--depends vala --depends libgee \
--license "LGPLv3" \
--url CI_PROJECT_URL \
--url $CI_PROJECT_URL \
--description "Vala projects and packages manager" \
-a $(uname -m) \
-C ./build/ \
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment