Commit 8d2c7648 authored by Vivien Kraus's avatar Vivien Kraus
Browse files

Make my life easier.

parent fad3bdf3
Pipeline #27478 passed with stage
in 2 minutes and 12 seconds
......@@ -5,5 +5,6 @@ RUN apt-get install -y --no-install-recommends autoconf automake gettext autopoi
RUN apt-get install -y --no-install-recommends make gcc valac valac-vapi gtk-doc-tools
RUN apt-get install -y --no-install-recommends nettle-dev libgtk-3-dev libgirepository1.0-dev
RUN apt-get install -y --no-install-recommends emacs org-mode
RUN apt-get install -y --no-install-recommends indent
RUN apt-get upgrade -y
MAINTAINER framagit.org/gugurumbe/tarot
\ No newline at end of file
......@@ -35,3 +35,12 @@ README.md: README.org
"README.org has changed but you don't have emacs installed." \
&& exit 1
endif
if HAVE_DOCKER
.PHONY: docker-build docker-upload
docker-build:
$(DOCKER) build --no-cache -t tarotbis/build:latest $(srcdir)
docker-upload: docker-build
$(DOCKER) push tarotbis/build:latest
endif
......@@ -16,6 +16,7 @@ AM_INIT_AUTOMAKE([subdir-objects])
AM_PROG_AR
LT_INIT
AX_INDENT
AX_DOCKER
AX_ORGMODE
gl_INIT
......
AC_DEFUN([AX_DOCKER], [
AC_ARG_ENABLE([docker],
[AS_HELP_STRING([--enable-docker],
[use the docker program to build and upload the docker image
used in CI (required for the maintainer, default: if available)])])
AC_ARG_VAR([DOCKER],
[docker program (optional, but needed for the maintainer, pass
'no' to disable the check])
AS_IF([test "x$DOCKER" != "xno"], [
AC_PATH_PROG([DOCKER], [docker], [no])
])
AM_CONDITIONAL([HAVE_DOCKER], [test "x$DOCKER" != "xno"])
AS_IF([test "x$enable_docker" = "xyes" && test "x$DOCKER" = "xno"],
AC_MSG_FAILURE([Requested docker program not found.]))
])
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment