Commit fe40d551 authored by Eric Vidal's avatar Eric Vidal 💬
Browse files

upgpkg: 2.23.1-2

parent 78a2fa2a
Pipeline #166022 passed with stages
in 5 minutes and 57 seconds
......@@ -21,7 +21,10 @@ build_repo:
script:
- cp ./${repo_conf} /etc/${repo_conf}
- builder.sh --chdir=trunk
retry:
max: 2
artifacts:
name: $CI_PROJECT_NAME-$CI_COMMIT_REF_NAME-$CI_COMMIT_SHORT_SHA
expire_in: 2 days
......
# Maintainer: Eric Vidal <eric@obarun.org>
# based on the original https://projects.archlinux.org/svntogit/packages.git/tree/trunk?h=packages/syslog-ng
# Maintainer: Eric Bélanger <eric@archlinux.org>
# Obarun : 66 init/supervisor
# Maintainer : Eric Vidal <eric@obarun.org>
# Maintainer : Jean-Michel T.Dydak <jean-michel@obarun.org>
# PkgSource : url="https://framagit.org/pkg/obextra/syslog-ng"
#-----------------------------------------------------------------------------------------------
#-----------------------------------------| DESCRIPTION |---------------------------------------
pkgname=syslog-ng
pkgver=3.22.1
pkgrel=2
pkgdesc="Next-generation syslogd with advanced networking and filtering capabilities"
arch=(x86_64)
pkgver=3.23.1
pkgrel=2
url="https://www.syslog-ng.com/products/open-source-log-management/"
license=('GPL2' 'LGPL2.1')
depends=('awk' 'glib2' 'glib2' 'libnsl' 'json-c' 'curl' 'libnet')
makedepends=('libxslt' 'mongo-c-driver' 'librabbitmq-c' 'python' 'libesmtp' 'hiredis'
'libdbi' 'geoip' 'libmaxminddb' 'net-snmp')
checkdepends=('python-nose' 'python-pylint' 'python-ply')
optdepends=('logrotate: for rotating log files'
'libdbi: for the SQL plugin'
'librabbitmq-c: for the AMQP plugin'
'mongo-c-driver: for the MongoDB plugin'
'python: for the Python plugin'
'libesmtp: for the SMTP plugin'
'hiredis: for the Redis plugin'
'geoip: for the GeoIP plugin'
'libmaxminddb: for the GeoIP2 plugin'
'net-snmp: for the SNMP plugin'
'python: for Python-based plugins')
conflicts=('eventlog')
replaces=('eventlog')
backup=('etc/syslog-ng/scl.conf'
'etc/syslog-ng/syslog-ng.conf'
'etc/logrotate.d/syslog-ng')
source=(https://github.com/balabit/syslog-ng/releases/download/syslog-ng-$pkgver/$pkgname-$pkgver.tar.gz
track=
target="$pkgname-$pkgver.tar.gz"
source=(https://github.com/balabit/syslog-ng/releases/download/syslog-ng-$pkgver/${target}
syslog-ng.conf syslog-ng.logrotate)
sha1sums=('b083081bca113c1779ef8c5ef4eef20a3690be2a'
'a9b54de3e91921966562bd458db26dea135888ba'
'949128fe3d7f77a7aab99048061f885bc758000c')
#-------------------------------------| BUILD CONFIGURATION |-----------------------------------
makedepends=(
'libxslt'
'mongo-c-driver'
'librabbitmq-c'
'python'
'libesmtp'
'hiredis'
'libdbi'
'geoip'
'libmaxminddb'
'net-snmp')
checkdepends=(
'python-nose'
'python-pylint'
'python-ply')
#--------------------------------------------| BUILD |------------------------------------------
build() {
cd ${pkgname}-$pkgver
./autogen.sh
......@@ -60,11 +66,15 @@ build() {
make
}
#--------------------------------------------| CHECK |------------------------------------------
check() {
cd ${pkgname}-$pkgver
make check || /bin/true # python test requires pep8
}
#-------------------------------------------| PACKAGE |-----------------------------------------
package() {
make -C ${pkgname}-$pkgver DESTDIR="$pkgdir" install
install -dm755 "$pkgdir/var/lib/syslog-ng" "$pkgdir/etc/syslog-ng/patterndb.d"
......@@ -73,3 +83,44 @@ package() {
# this is not specific to systemd, the file can be sourced by any service file as classic bash operation
install -Dm644 "$srcdir"/$pkgname-$pkgver/contrib/systemd/syslog-ng@default -t "$pkgdir"/etc/default
}
#------------------------------------| INSTALL CONFIGURATION |----------------------------------
arch=(x86_64)
backup=('etc/syslog-ng/scl.conf'
'etc/syslog-ng/syslog-ng.conf'
'etc/logrotate.d/syslog-ng')
depends=(
'awk'
'glib2'
'glib2'
'libnsl'
'json-c'
'curl'
'libnet')
optdepends=('logrotate: for rotating log files'
'libdbi: for the SQL plugin'
'librabbitmq-c: for the AMQP plugin'
'mongo-c-driver: for the MongoDB plugin'
'python: for the Python plugin'
'libesmtp: for the SMTP plugin'
'hiredis: for the Redis plugin'
'geoip: for the GeoIP plugin'
'libmaxminddb: for the GeoIP2 plugin'
'net-snmp: for the SNMP plugin'
'python: for Python-based plugins')
conflicts=('eventlog')
replaces=('eventlog')
#-------------------------------------| SECURITY AND LICENCE |----------------------------------
license=('GPL2' 'LGPL2.1')
sha1sums=('b083081bca113c1779ef8c5ef4eef20a3690be2a'
'a9b54de3e91921966562bd458db26dea135888ba'
'949128fe3d7f77a7aab99048061f885bc758000c')
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment