Commit 46374aa2 authored by Jean-Francois Dockes's avatar Jean-Francois Dockes
Browse files

packaging and doc

parent 87be53e3
AC_INIT([upmpdcli], [1.2.4], [jfd@lesbonscomptes.com],
AC_INIT([upmpdcli], [1.2.5], [jfd@lesbonscomptes.com],
[upmpdcli], [http://www.lesbonscomptes.com/upmpdcli])
AC_PREREQ([2.53])
AC_CONFIG_SRCDIR([src/upmpd.cxx])
......
upmpdcli (1.2.5-1) unstable; urgency=low
* Tidal repaired thanks to the Kodi addon developers !
-- Jean-Francois Dockes <jf@dockes.org> Mon, 03 Oct 2016 18:54:00 +0200
upmpdcli (1.2.4-1) unstable; urgency=low
* Fix streaming service search (type was ignored)
* Fix crash with absent config
-- Jean-Francois Dockes <jf@dockes.org> Sat, 24 Sep 2016 19:23:00 +0200
-- Jean-Francois Dockes <jf@dockes.org> Mon, 03 Oct 2016 12:10:00 +0200
upmpdcli (1.2.3-1) unstable; urgency=low
......
......@@ -2,10 +2,13 @@ Source: upmpdcli
Section: contrib/sound
Priority: extra
Maintainer: Jean-Francois Dockes <jf@dockes.org>
# note: libexpat1-dev and libcurl-dev are only here because of pkg-config:
# not directly needed for building upmpdcli
Build-Depends: debhelper (>= 9.0.0), dh-python, dh-systemd,
autotools-dev, python, pkg-config,
libmpdclient-dev, libmicrohttpd-dev, python-requests,
libupnpp3-dev, libupnp6-dev, libjsoncpp-dev
libupnpp3-dev, libupnp6-dev, libjsoncpp-dev,
libexpat1-dev, libcurl-dev
Standards-Version: 3.9.6
Homepage: http://www.lesbonscomptes.com/upmpdcli
......
......@@ -5,7 +5,8 @@ Maintainer: Jean-Francois Dockes <jf@dockes.org>
Build-Depends: debhelper (>= 9.0.0), dh-python,
autotools-dev, python, pkg-config,
libmpdclient-dev, libmicrohttpd-dev, python-requests,
libupnpp3-dev, libupnp6-dev, libjsoncpp-dev
libupnpp3-dev, libupnp6-dev, libjsoncpp-dev,
libexpat1-dev, libcurl-dev
Standards-Version: 3.9.6
Homepage: http://www.lesbonscomptes.com/upmpdcli
......
= Upmpdcli release notes
== Upmpdcli 1.2.5
- Tidal repaired (you only need the tidal Python code, the rest of upmpdcli
is unchanged).
== Upmpdcli 1.2.4
- Misc bug fixes.
- Split the Debian / Ubuntu packages to separate the main package from the
different streaming services ones.
== Upmpdcli 1.2.0
- Implement gateway to Google Play Music, Qobuz and Tidal by exporting a
......
......@@ -46,8 +46,8 @@ https://github.com/medoc92/upmpdcli/issues/36#issuecomment-227761220
Upmpdcli versions 1.2.0 and later offer support for accessing music on some
streaming services. You will need a valid account on the services you want
to use. The initial release supports Google Play Music, Qobuz and Tidal
(which does not work any more, see the notes in the Tidal section).
to use. The initial release supports Google Play Music, Qobuz and Tidal.
When the function is activated, upmpdcli creates a separate auxiliary Media
Server, with the sole purpose of presenting the streaming server
......@@ -88,7 +88,10 @@ The Tidal module code is is based on the
link:https://github.com/tamland/kodi-tidal[Kodi Tidal add-on] and the
link:https://github.com/tamland/python-tidal[Tidal API], by Thomas
Amland (also using other useful modules by Thomas). I was able to reuse
most of the Kodi code.
most of the Kodi code.
The Tidal api module was recently updated and the login code comes from
link:https://github.com/arnesongit/kodi-tidal[this Git repository].
The software is not officially supported by Tidal, and may just stop to
work one day...
......@@ -98,12 +101,6 @@ It only works with a valid Tidal subscription.
The configuration parameters are described
link:#_tidal_streaming_service_parameters[further down].
NOTE: as of 2016-09-17, the Tidal interface does not seem to work any
more. It appears that the Kodi add-on has problems too, so this probably
comes from a change on the Tidal side, maybe they invalidated the API key
which was used by most open-source interfaces.
=== Notes on the Qobuz interface
This is based on the service API from the
......
Supports Markdown
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment