Commit 805e2c87 authored by berumuron's avatar berumuron
Browse files

Add python-ldap to requirements

parent 00fc16aa
......@@ -71,7 +71,13 @@ désactiver l'environnement avec (ne le faites toutefois pas immédiatement) :
reflets$ deactivate
```
Pour installer maintenant les sources du projet, exécutez :
Reflets permet de se connecter en LDAP et nécessite pour cela du module
[python-ldap](https://www.python-ldap.org). Ce module nécessite d’installer des
dépendances supplémentaires depuis votre gestionnaire de paquets. Vous pourrez
trouver la commande à exécuter [dans leur documentation
officielle](https://www.python-ldap.org/en/python-ldap-3.2.0/installing.html#build-prerequisites).
Pour installer maintenant les dépendances du projet, exécutez :
```console
reflets$ pip install -r requirements.txt
......
......@@ -5,6 +5,9 @@ itsdangerous==1.1.0
Jinja2==2.10.1
Markdown==3.1.1
MarkupSafe==1.1.1
pyasn1==0.4.6
pyasn1-modules==0.2.6
python-ldap==3.2.0
six==1.12.0
webencodings==0.5.1
Werkzeug==0.15.4
......@@ -27,3 +27,4 @@ install_requires =
Flask>=1.0.3
Markdown>=3.1.1
bleach>=3.1.0
python-ldap==3.2.0
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment