1. 14 Apr, 2017 1 commit
    • Klaus Weidenbach's avatar
      Update SimplePie library. · b6459e61
      Klaus Weidenbach authored
      As a follow up to issue #699 update SimplePie from 1.2.1-dev (around
      6years old) to current git master (1.4.4-dev). We use the master branch
      until the next release because it contains our patch for enclosure
      titles already. The other patches in the library from us can be done by
      configuring the SimplePie object in our code instead.
      Used composer to manage this library and use class autoloading.
      Add some unit tests for include/feedutils.php, but the interesting parts
      are unfortunately not testable with the current code.
      b6459e61
  2. 25 Mar, 2017 1 commit
  3. 19 Mar, 2017 1 commit
  4. 14 Mar, 2017 1 commit
  5. 05 Mar, 2017 1 commit
    • Klaus Weidenbach's avatar
      🔨 Upgrade Markdownify library. · 6c79e0c0
      Klaus Weidenbach authored
      The current version 2.0.0 (alpha) throws deprecated warning with
      PHP7.1 and PHPUnit.
      Upgrade the HTML to Markdown converter for PHP to the current
      Markdownify 2.2.1.
      Used composer to manage this library.
      6c79e0c0
  6. 27 Feb, 2017 1 commit
    • Klaus Weidenbach's avatar
      🔨 Upgrade PHP Markdown library. · 503c368f
      Klaus Weidenbach authored
      The current version throws deprecated warning with PHP7.1 and PHPUnit.
      Upgrade the Markdown library to the current PHP Markdown Lib 1.7.0.
      Used composer to manage this library.
      503c368f
  7. 18 Oct, 2016 1 commit
    • Klaus Weidenbach's avatar
      [FEATURE] Add config and use composer autoloader. · 745515b1
      Klaus Weidenbach authored
      We use composer already to install SabreDAV. Include config
      composer.(json|lock) to install and manage more dependencies
      in future.
      Also provide PSR-4 autoloading for our namespaced classes, e.g.
      "Zotlabs\". To regenerate autoloader maps use:
      $ composer install --optimize-autoloader --no-dev
      
      We could also remove the whole vendor/ folder from our repository, but
      that would need changes in deployment and how to install hubs and needs
      more discussion first.
      745515b1
  8. 28 Jun, 2016 1 commit
  9. 29 May, 2016 1 commit
  10. 28 May, 2016 1 commit
  11. 11 May, 2016 1 commit