Verified Commit bfcaa9c1 authored by Chocobozzz's avatar Chocobozzz
Browse files

Upgrade client dependencies

parent b4890f21
......@@ -183,6 +183,14 @@
"video.js",
"sha.js",
"postcss",
"focus-visible",
"path-browserify",
"deep-merge",
"escape-string-regexp",
"mousetrap",
"is-plain-object",
"parse-srcset",
"deepmerge",
"core-js/features/reflect"
],
"scripts": [],
......
......@@ -27,11 +27,11 @@
"typings": "*.d.ts",
"devDependencies": {
"@angular-devkit/build-angular": "^14.0.1",
"@angular-eslint/builder": "13.5.0",
"@angular-eslint/eslint-plugin": "13.5.0",
"@angular-eslint/eslint-plugin-template": "13.5.0",
"@angular-eslint/schematics": "13.5.0",
"@angular-eslint/template-parser": "13.5.0",
"@angular-eslint/builder": "14.0.2",
"@angular-eslint/eslint-plugin": "14.0.2",
"@angular-eslint/eslint-plugin-template": "14.0.2",
"@angular-eslint/schematics": "14.0.2",
"@angular-eslint/template-parser": "14.0.2",
"@angular/animations": "^14.0.1",
"@angular/cdk": "^14.0.1",
"@angular/cli": "^14.0.1",
......@@ -69,8 +69,8 @@
"@types/sha.js": "^2.4.0",
"@types/video.js": "^7.3.40",
"@types/webtorrent": "^0.109.0",
"@typescript-eslint/eslint-plugin": "5.27.1",
"@typescript-eslint/parser": "5.27.1",
"@typescript-eslint/eslint-plugin": "5.31.0",
"@typescript-eslint/parser": "5.31.0",
"@wdio/browserstack-service": "^7.20.2",
"@wdio/cli": "^7.20.2",
"@wdio/local-runner": "^7.20.2",
......@@ -84,7 +84,7 @@
"cache-chunk-store": "^3.0.0",
"chart.js": "^3.8.0",
"chartjs-plugin-zoom": "^1.2.1",
"chromedriver": "^102.0.0",
"chromedriver": "^103.0.0",
"core-js": "^3.22.8",
"css-loader": "^6.2.0",
"debug": "^4.3.1",
......@@ -96,8 +96,8 @@
"expect-webdriverio": "^3.4.0",
"focus-visible": "^5.0.2",
"geckodriver": "^3.0.1",
"hls.js": "1.2.0-beta.2",
"html-loader": "^3.0.1",
"hls.js": "1.2.0",
"html-loader": "^4.1.0",
"html-webpack-plugin": "^5.3.1",
"https-browserify": "^1.0.0",
"intl-messageformat": "^10.1.0",
......@@ -111,7 +111,7 @@
"ngx-uploadx": "^5.1.0",
"path-browserify": "^1.0.0",
"postcss": "^8.4.14",
"primeng": "^13.4.1",
"primeng": "^14.0.0",
"process": "^0.11.10",
"purify-css": "^1.2.5",
"querystring": "^0.2.1",
......@@ -133,7 +133,7 @@
"video.js": "^7.19.2",
"videostream": "~3.2.1",
"wdio-chromedriver-service": "^7.3.2",
"wdio-geckodriver-service": "^2.1.1",
"wdio-geckodriver-service": "^3.0.2",
"webpack": "^5.73.0",
"webpack-bundle-analyzer": "^4.4.2",
"webpack-cli": "^4.10.0",
......
......@@ -5,6 +5,7 @@
@import '~bootstrap/scss/functions';
@import '~bootstrap/scss/variables';
@import '~bootstrap/scss/maps';
@import '~bootstrap/scss/mixins';
@import '~bootstrap/scss/utilities';
......@@ -29,6 +30,11 @@
@import '~bootstrap/scss/helpers';
@import '~bootstrap/scss/utilities/api';
.accordion {
--bs-accordion-color: #{pvar(--mainForegroundColor)};
--bs-accordion-bg: #{pvar(--mainBackgroundColor)};
}
.flex-auto {
flex: auto;
}
......
......@@ -51,8 +51,6 @@ $dropdown-link-hover-bg: pvar(--mainBackgroundHoverColor);
$dropdown-color: pvar(--mainForegroundColor);
$dropdown-bg: pvar(--mainBackgroundColor);
$accordion-color: pvar(--mainForegroundColor);
$accordion-bg: pvar(--mainBackgroundColor);
$accordion-button-active-bg: pvar(--mainColorVeryLight);
$accordion-button-active-color: pvar(--mainForegroundColor);
$accordion-button-focus-border-color: pvar(--mainColorLightest);
......
This diff is collapsed.
Supports Markdown
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment