Verified Commit 60f1f615 authored by Chocobozzz's avatar Chocobozzz
Browse files

Fix ffmpeg version checker

parent 16de9ff4
......@@ -679,10 +679,16 @@ function getFFmpegVersion () {
return execPromise(`${ffmpegPath} -version`)
.then(stdout => {
const parsed = stdout.match(/ffmpeg version .?(\d+\.\d+\.\d+)/)
const parsed = stdout.match(/ffmpeg version .?(\d+\.\d+(\.\d+)?)/)
if (!parsed || !parsed[1]) return rej(new Error(`Could not find ffmpeg version in ${stdout}`))
return res(parsed[1])
// Fix ffmpeg version that does not include patch version (4.4 for example)
let version = parsed[1]
if (version.match(/^\d+\.\d+/)) {
version += '.0'
}
return res(version)
})
.catch(err => rej(err))
})
......
Supports Markdown
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment