Commit 388f77a0 authored by François Perrad's avatar François Perrad

rockspec with framagit

parent 00f8b148
package = 'lua-CoatPersistent-lsqlite3'
version = '@version@-@rev@'
source = {
url = 'http://github.com/fperrad/lua-CoatPersistent/raw/releases/lua-coatpersistent-@version@.tar.gz',
url = 'https://framagit.org/fperrad/lua-CoatPersistent/raw/releases/lua-coatpersistent-@version@.tar.gz',
md5 = '@md5@',
dir = 'lua-CoatPersistent-@version@',
}
......@@ -11,7 +11,7 @@ description = {
lua-CoatPersistent is an Object-Relational Mapping for lua-Coat.
This variant is built over the modules lsqlite3 and Dado.
]],
homepage = 'http://fperrad.github.io/lua-CoatPersistent',
homepage = 'http://fperrad.frama.io/lua-CoatPersistent',
maintainer = 'Francois Perrad',
license = 'MIT/X11'
}
......@@ -20,7 +20,6 @@ dependencies = {
'lsqlite3 >= 0.7',
'dado >= 1.2.0',
'lua-coat >= 0.9.0',
'lua-testmore >= 0.2.3',
}
build = {
type = 'builtin',
......
package = 'lua-CoatPersistent-LuaSQL'
version = '@version@-@rev@'
source = {
url = 'http://github.com/fperrad/lua-CoatPersistent/raw/releases/lua-coatpersistent-@version@.tar.gz',
url = 'https://framagit.org/fperrad/lua-CoatPersistent/raw/releases/lua-coatpersistent-@version@.tar.gz',
md5 = '@md5@',
dir = 'lua-CoatPersistent-@version@',
}
......@@ -12,7 +12,7 @@ description = {
This variant is built over the modules LuaSQL and Dado.
It could support all database engine which has a driver in LuaSQL.
]],
homepage = 'http://fperrad.github.io/lua-CoatPersistent',
homepage = 'http://fperrad.frama.io/lua-CoatPersistent',
maintainer = 'Francois Perrad',
license = 'MIT/X11'
}
......@@ -21,7 +21,6 @@ dependencies = {
'luasql-sqlite3 >= 2.2.0',
'dado >= 1.2.0',
'lua-coat >= 0.9.0',
'lua-testmore >= 0.2.3',
}
build = {
type = 'builtin',
......
package = 'lua-CoatPersistent-lsqlite3'
version = '0.2.2-2'
source = {
url = 'https://framagit.org/fperrad/lua-CoatPersistent/raw/releases/lua-coatpersistent-0.2.2.tar.gz',
md5 = '1e10d7530bd5a01aa2fb4b0633623008',
dir = 'lua-CoatPersistent-0.2.2',
}
description = {
summary = "an ORM for lua-Coat",
detailed = [[
lua-CoatPersistent is an Object-Relational Mapping for lua-Coat.
This variant is built over the modules lsqlite3 and Dado.
]],
homepage = 'http://fperrad.frama.io/lua-CoatPersistent',
maintainer = 'Francois Perrad',
license = 'MIT/X11'
}
dependencies = {
'lua >= 5.1',
'lsqlite3 >= 0.7',
'dado >= 1.2.0',
'lua-coat >= 0.9.0',
}
build = {
type = 'builtin',
modules = {
['Coat.Persistent'] = 'src.lsqlite3/Coat/Persistent.lua',
},
copy_directories = { 'docs', 'test' },
}
package = 'lua-CoatPersistent-LuaSQL'
version = '0.2.2-2'
source = {
url = 'https://framagit.org/fperrad/lua-CoatPersistent/raw/releases/lua-coatpersistent-0.2.2.tar.gz',
md5 = '1e10d7530bd5a01aa2fb4b0633623008',
dir = 'lua-CoatPersistent-0.2.2',
}
description = {
summary = "an ORM for lua-Coat",
detailed = [[
lua-CoatPersistent is an Object-Relational Mapping for lua-Coat.
This variant is built over the modules LuaSQL and Dado.
It could support all database engine which has a driver in LuaSQL.
]],
homepage = 'http://fperrad.frama.io/lua-CoatPersistent',
maintainer = 'Francois Perrad',
license = 'MIT/X11'
}
dependencies = {
'lua >= 5.1',
'luasql-sqlite3 >= 2.2.0',
'dado >= 1.2.0',
'lua-coat >= 0.9.0',
}
build = {
type = 'builtin',
modules = {
['Coat.Persistent'] = 'src/Coat/Persistent.lua',
},
copy_directories = { 'docs', 'test' },
}
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment