Commit 8cd9d406 authored by Daniel Caillibaud's avatar Daniel Caillibaud

fix update by cli

parent b8c8c8fd
...@@ -58,7 +58,7 @@ function applyUpdate (updateNum, done) { ...@@ -58,7 +58,7 @@ function applyUpdate (updateNum, done) {
if (obj2dump) console.error(obj2dump) if (obj2dump) console.error(obj2dump)
} }
const updateFile = path.join(__dirname, 'updates', updateNum + '.js') const updateFile = path.join(__dirname, 'updates', updateNum + '.js')
const lockFile = path.join(__dirname, '../../_private/updates.lock') const lockFile = path.join(__dirname, '../../../_private/updates.lock')
if (fs.existsSync(lockFile)) return done(new Error(`${lockFile} présent, on ne peut pas lancer ${updateFile}`)) if (fs.existsSync(lockFile)) return done(new Error(`${lockFile} présent, on ne peut pas lancer ${updateFile}`))
// on le crée (en mettant dedans l'update qu'on va appliquer) // on le crée (en mettant dedans l'update qu'on va appliquer)
else fs.appendFileSync(lockFile, updateFile) else fs.appendFileSync(lockFile, updateFile)
......
...@@ -14,6 +14,7 @@ dependencies: ...@@ -14,6 +14,7 @@ dependencies:
elementtree: 0.1.7 elementtree: 0.1.7
eslint-import-resolver-node: 0.3.2 eslint-import-resolver-node: 0.3.2
express: 4.16.4 express: 4.16.4
glob: 7.1.4
history: 4.9.0 history: 4.9.0
html-to-text: 4.0.0 html-to-text: 4.0.0
ip: 1.1.5 ip: 1.1.5
...@@ -4530,6 +4531,17 @@ packages: ...@@ -4530,6 +4531,17 @@ packages:
path-is-absolute: 1.0.1 path-is-absolute: 1.0.1
resolution: resolution:
integrity: sha512-vcfuiIxogLV4DlGBHIUOwI0IbrJ8HWPc4MU7HzviGeNho/UJDfi6B5p3sHeWIQ0KGIU0Jpxi5ZHxemQfLkkAwQ== integrity: sha512-vcfuiIxogLV4DlGBHIUOwI0IbrJ8HWPc4MU7HzviGeNho/UJDfi6B5p3sHeWIQ0KGIU0Jpxi5ZHxemQfLkkAwQ==
/glob/7.1.4:
dependencies:
fs.realpath: 1.0.0
inflight: 1.0.6
inherits: 2.0.3
minimatch: 3.0.4
once: 1.4.0
path-is-absolute: 1.0.1
dev: false
resolution:
integrity: sha512-hkLPepehmnKk41pUGm3sYxoFs/umurYfYJCerbXEyFIWcAzvpipAgVkBqqT9RBKMGjnq6kMuyYwha6csxbiM1A==
/global-dirs/0.1.1: /global-dirs/0.1.1:
dependencies: dependencies:
ini: 1.3.5 ini: 1.3.5
...@@ -10962,6 +10974,7 @@ specifiers: ...@@ -10962,6 +10974,7 @@ specifiers:
express: ^4.16.2 express: ^4.16.2
faker: ^4.1.0 faker: ^4.1.0
file-loader: ^3.0.1 file-loader: ^3.0.1
glob: ^7.1.4
history: ^4.7.2 history: ^4.7.2
html-to-text: ^4.0.0 html-to-text: ^4.0.0
ignore-styles: ^5.0.1 ignore-styles: ^5.0.1
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment