Commit 1922e5e2 authored by HS-157's avatar HS-157
Browse files

Rajout de gestionnaire de greffon

parent eb994681
......@@ -6,34 +6,22 @@ set ruler " Montre toujours la position du curseur
set cursorline " Ajout d'une ligne colorée pour surligné la ligne en cours
set ttyfast " Connexion rapide au terminal : améliore la rapidité d'affichage
set number " Affiche les numéros de ligne
set showmatch "Affiche les paires de parenthèses
set showmatch " Affiche les paires de parenthèses
set tabstop=4 " Indentation de tab de 4 espace
set smartindent
set autoindent
set backspace=indent,eol,start
set ruler
set mouse=ai " Souris utilisable
set mouse=ai " Souris utilisable
set showcmd " Affiche les raccoucis quand on les tape
set history=10000 " Historique des commandes
" Ouverture des fichiers avec le curseur à la position de la dernière édition
function! s:Cursor0ldPosition()
if line("'\"") > 0 && line("'\"") <= line("$")
exe "normal g`\""
endif
endfunction
autocmd BufReadPost * silent! call s:CursorOldPosition()
" Sauvegarde rapide du fichier actuel
" Sauvegarde rapde du fichier actuel en appyant sur F2
map <F2> :w<CR>
imap <F2> <ESC>:w<CR>
" Initialisation de pathogen
call pathogen#infect()
call pathogen#helptags()
" Choix du thème
" Activation de la coloration syntaxique
syntax enable
set background=dark
" Rajoute +x pour tout fichier commençant par #!<n'importe quel caractère>/bin/
function ModeChange()
......@@ -42,3 +30,35 @@ function ModeChange()
endif
endfunction
au BufWritePost * call ModeChange()
" Note: Skip initialization for vim-tiny or vim-small.
if 0 | endif
if has('vim_starting')
if &compatible
set nocompatible " Be iMproved
endif
" Required:
set runtimepath+=~/.vim/bundle/neobundle.vim/
endif
" Required:
call neobundle#begin(expand('~/.vim/bundle/'))
" Let NeoBundle manage NeoBundle
" Required:
NeoBundleFetch 'Shougo/neobundle.vim'
" Liste des greffons
NeoBundle 'lilydjwg/colorizer' " Coloration du code couleur
NeoBundle 'indentpython.vim' " Indentation pour Python
call neobundle#end()
" Required:
filetype plugin indent on
" If there are uninstalled bundles found on startup,
" this will conveniently prompt you to install them.
NeoBundleCheck
Supports Markdown
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment