Unverified Commit 03586847 authored by Denis 'GNUtoo' Carikli's avatar Denis 'GNUtoo' Carikli
Browse files

Fix lightdm-gtk-greeter



checking for exo-csource... no
configure: error: in `/tmp/guix-build-lightdm-gtk-greeter-2.0.7.drv-0/lightdm-gtk-greeter-2.0.7':
configure: error: exo-csource not installed
See `config.log' for more details
command "/gnu/store/v1g7f3p4f0851mywrla8qmr9hb8jgfjr-bash-minimal-5.0.16/bin/bash" "./configure" "CONFIG_SHELL=/gnu/store/v1g7f3p4f0851mywrla8qmr9hb8jgfjr-bash-minimal-5.0.16/bin/bash" "SHELL=/gnu/store/v1g7f3p4f0851mywrla8qmr9hb8jgfjr-bash-minimal-5.0.16/bin/bash" "--prefix=/gnu/store/67p3agyzwd65hsa43hkb6cm07xbxqhp2-lightdm-gtk-greeter-2.0.7" "--enable-fast-install" "--build=i686-unknown-linux-gnu" "--enable-at-spi-command=/gnu/store/p3adnp23dqb04p43zk4yx0psyh5a1yiw-at-spi2-core-2.34.0/libexec/at-spi-bus-launcher" failed with status 1
Signed-off-by: Denis 'GNUtoo' Carikli's avatarDenis 'GNUtoo' Carikli <GNUtoo@cyberdimension.org>
parent 15c91189
......@@ -260,16 +260,16 @@ display manager which supports different greeters.")
(define-public lightdm-gtk-greeter
(package
(name "lightdm-gtk-greeter")
(version "2.0.7")
(version "2.0.8")
(source (origin
(method url-fetch)
(uri (string-append
"https://launchpad.net/lightdm-gtk-greeter/"
(version-major+minor version) "/" version
"/+download/lightdm-gtk-greeter-" version ".tar.gz"))
"https://github.com/xubuntu/lightdm-gtk-greeter"
"/releases/download/lightdm-gtk-greeter-" version "/"
"lightdm-gtk-greeter-" version ".tar.gz"))
(sha256
(base32
"1g7wc3d3vqfa7mrdhx1w9ywydgjbffla6rbrxq9k3sc62br97qms"))))
"04q62mvr97l9gv8h37hfarygqc7p0498ig7xclcg4kxkqw0b7yxy"))))
(build-system gnu-build-system)
(arguments
`(#:configure-flags
......@@ -304,14 +304,15 @@ display manager which supports different greeters.")
(native-inputs
`(("exo" ,exo)
("intltool" ,intltool)
("pkg-config" ,pkg-config)))
("pkg-config" ,pkg-config)
("xfce4-dev-tools" ,xfce4-dev-tools)))
(inputs
`(("lightdm" ,lightdm)
("shared-mime-info" ,shared-mime-info)
("at-spi2-core" ,at-spi2-core)
("gtk+" ,gtk+)))
(synopsis "GTK+ greeter for LightDM")
(home-page "https://launchpad.net/lightdm-gtk-greeter")
(home-page "https://github.com/xubuntu/lightdm-gtk-greeter")
(description "This package provides a LightDM greeter implementation using
GTK+, lets you select a desktop session and log in to it.")
(license license:gpl3+)))
......
......@@ -2130,3 +2130,28 @@ lan interface (signal state, signal quality, network name (SSID)).")
local weather in the panel, using forecast data provided by the
@uref{https://met.no, Norwegian Meteorological Institute}.")
(license gpl2+)))
(define-public xfce4-dev-tools
(package
(name "xfce4-dev-tools")
(version "4.17.0")
(source (origin
(method url-fetch)
(uri (string-append "https://archive.xfce.org/src/xfce/"
"xfce4-dev-tools/" (version-major+minor version) "/"
"xfce4-dev-tools-" version ".tar.bz2"))
(sha256
(base32
"1iwkqj96x2s7fk4srg1pymvsiwb2rn6vvhy6hrmnc3hl1vqw2d6k"))))
(build-system gnu-build-system)
(native-inputs
`(("pkg-config" ,pkg-config)))
(inputs
`(("glib" ,glib)))
(home-page "https://docs.xfce.org/xfce/xfce4-dev-tools/")
(synopsis "Xfce developer tools")
(description
"The Xfce development tools are a collection of tools and macros for Xfce
developers and people that want to build Xfce from Git In addition it contains
the Xfce developer's handbook.")
(license gpl2+)))
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment