Commit 59dc1328 authored by Alexandre Friquet's avatar Alexandre Friquet

Upgrades Rails from 5.1.4 to 5.1.6: refs #92.

parent 77600215
......@@ -22,7 +22,7 @@
#
source 'https://rubygems.org'
gem 'rails', '5.1.4'
gem 'rails', '5.1.6'
gem 'sass-rails'
gem 'uglifier'
gem 'coffee-rails'
......@@ -77,7 +77,8 @@ group :test do
gem 'shoulda-matchers', git: 'https://github.com/thoughtbot/shoulda-matchers.git', branch: 'rails-5'
gem 'test-unit', '~> 3.0' # For shoulda-matchers with ruby 2.3+
gem 'database_cleaner'
gem 'capybara-webkit'
# see https://github.com/thoughtbot/capybara-webkit/issues/1065
gem 'capybara-webkit', github: 'thoughtbot/capybara-webkit', branch: 'master'
gem 'fuubar'
gem 'faker'
end
......
GIT
remote: git://github.com/thoughtbot/capybara-webkit.git
revision: 41c43062677c1628e09f9dc00dc24528ba161ed7
branch: master
specs:
capybara-webkit (1.15.0)
capybara (>= 2.3, < 4.0)
json
GIT
remote: https://git.framasoft.org/infopiiaf/piwik_analytics.git
revision: 9fed6d03734fad27ea513e5f1e57d2771d9cbdf6
......@@ -37,41 +46,41 @@ GEM
remote: https://rubygems.org/
specs:
RedCloth (4.3.2)
actioncable (5.1.4)
actionpack (= 5.1.4)
actioncable (5.1.6)
actionpack (= 5.1.6)
nio4r (~> 2.0)
websocket-driver (~> 0.6.1)
actionmailer (5.1.4)
actionpack (= 5.1.4)
actionview (= 5.1.4)
activejob (= 5.1.4)
actionmailer (5.1.6)
actionpack (= 5.1.6)
actionview (= 5.1.6)
activejob (= 5.1.6)
mail (~> 2.5, >= 2.5.4)
rails-dom-testing (~> 2.0)
actionpack (5.1.4)
actionview (= 5.1.4)
activesupport (= 5.1.4)
actionpack (5.1.6)
actionview (= 5.1.6)
activesupport (= 5.1.6)
rack (~> 2.0)
rack-test (>= 0.6.3)
rails-dom-testing (~> 2.0)
rails-html-sanitizer (~> 1.0, >= 1.0.2)
actionview (5.1.4)
activesupport (= 5.1.4)
actionview (5.1.6)
activesupport (= 5.1.6)
builder (~> 3.1)
erubi (~> 1.4)
rails-dom-testing (~> 2.0)
rails-html-sanitizer (~> 1.0, >= 1.0.3)
activejob (5.1.4)
activesupport (= 5.1.4)
activejob (5.1.6)
activesupport (= 5.1.6)
globalid (>= 0.3.6)
activemodel (5.1.4)
activesupport (= 5.1.4)
activerecord (5.1.4)
activemodel (= 5.1.4)
activesupport (= 5.1.4)
activemodel (5.1.6)
activesupport (= 5.1.6)
activerecord (5.1.6)
activemodel (= 5.1.6)
activesupport (= 5.1.6)
arel (~> 8.0)
activesupport (5.1.4)
activesupport (5.1.6)
concurrent-ruby (~> 1.0, >= 1.0.2)
i18n (~> 0.7)
i18n (>= 0.7, < 2)
minitest (~> 5.1)
tzinfo (~> 1.1)
acts_as_list (0.9.7)
......@@ -88,16 +97,13 @@ GEM
brakeman (3.7.2)
builder (3.2.3)
byebug (9.1.0)
capybara (2.13.0)
capybara (3.7.1)
addressable
mime-types (>= 1.16)
nokogiri (>= 1.3.3)
rack (>= 1.0.0)
rack-test (>= 0.5.4)
xpath (~> 2.0)
capybara-webkit (1.14.0)
capybara (>= 2.3.0, < 2.14.0)
json
mini_mime (>= 0.1.3)
nokogiri (~> 1.8)
rack (>= 1.6.0)
rack-test (>= 0.6.3)
xpath (~> 3.1)
chunky_png (1.3.8)
climate_control (0.2.0)
clipboard-rails (1.7.1)
......@@ -129,7 +135,7 @@ GEM
concurrent-ruby (1.0.5)
crack (0.4.3)
safe_yaml (~> 1.0.0)
crass (1.0.2)
crass (1.0.4)
daemons (1.2.4)
database_cleaner (1.6.1)
delayed_job (4.1.3)
......@@ -143,7 +149,7 @@ GEM
dotenv-rails (2.2.1)
dotenv (= 2.2.1)
railties (>= 3.2, < 5.2)
erubi (1.6.1)
erubi (1.7.1)
execjs (2.7.0)
extlib (0.9.16)
factory_girl (4.8.0)
......@@ -168,7 +174,7 @@ GEM
rspec-core (~> 3.0)
ruby-progressbar (~> 1.4)
geocoder (1.4.9)
globalid (0.4.0)
globalid (0.4.1)
activesupport (>= 4.2.0)
google-api-client (0.8.6)
activesupport (>= 3.2)
......@@ -192,7 +198,8 @@ GEM
gretel (3.0.9)
rails (>= 3.1.0)
hirb (0.7.3)
i18n (0.8.6)
i18n (0.9.5)
concurrent-ruby (~> 1.0)
jquery-minicolors-rails (2.2.6.0)
jquery-rails
rails (>= 3.2.8)
......@@ -216,26 +223,27 @@ GEM
logging (2.2.2)
little-plugger (~> 1.1)
multi_json (~> 1.10)
loofah (2.1.1)
loofah (2.2.2)
crass (~> 1.0.2)
nokogiri (>= 1.5.9)
mail (2.6.6)
mime-types (>= 1.16, < 4)
mail (2.7.0)
mini_mime (>= 0.1.1)
memoist (0.16.0)
method_source (0.9.0)
mime-types (3.1)
mime-types (3.2.2)
mime-types-data (~> 3.2015)
mime-types-data (3.2016.0521)
mime-types-data (3.2018.0812)
mimemagic (0.3.2)
mini_mime (1.0.1)
mini_portile2 (2.3.0)
minitest (5.10.3)
minitest (5.11.3)
momentjs-rails (2.17.1)
railties (>= 3.1)
multi_json (1.12.2)
multipart-post (2.0.0)
nested_form (0.3.2)
nio4r (2.1.0)
nokogiri (1.8.1)
nio4r (2.3.1)
nokogiri (1.8.4)
mini_portile2 (~> 2.3.0)
os (0.9.6)
paperclip (5.1.0)
......@@ -251,35 +259,35 @@ GEM
rails (>= 3.1)
sass-rails
uglifier
public_suffix (3.0.0)
public_suffix (3.0.3)
puma (3.10.0)
rack (2.0.3)
rack-test (0.7.0)
rack (2.0.5)
rack-test (1.1.0)
rack (>= 1.0, < 3)
rails (5.1.4)
actioncable (= 5.1.4)
actionmailer (= 5.1.4)
actionpack (= 5.1.4)
actionview (= 5.1.4)
activejob (= 5.1.4)
activemodel (= 5.1.4)
activerecord (= 5.1.4)
activesupport (= 5.1.4)
rails (5.1.6)
actioncable (= 5.1.6)
actionmailer (= 5.1.6)
actionpack (= 5.1.6)
actionview (= 5.1.6)
activejob (= 5.1.6)
activemodel (= 5.1.6)
activerecord (= 5.1.6)
activesupport (= 5.1.6)
bundler (>= 1.3.0)
railties (= 5.1.4)
railties (= 5.1.6)
sprockets-rails (>= 2.0.0)
rails-dom-testing (2.0.3)
activesupport (>= 4.2.0)
nokogiri (>= 1.6)
rails-html-sanitizer (1.0.3)
loofah (~> 2.0)
railties (5.1.4)
actionpack (= 5.1.4)
activesupport (= 5.1.4)
rails-html-sanitizer (1.0.4)
loofah (~> 2.2, >= 2.2.2)
railties (5.1.6)
actionpack (= 5.1.6)
activesupport (= 5.1.6)
method_source
rake (>= 0.8.7)
thor (>= 0.18.1, < 2.0)
rake (12.1.0)
rake (12.3.1)
rb-fsevent (0.10.2)
rb-inotify (0.9.10)
ffi (>= 0.5.0, < 2)
......@@ -325,7 +333,7 @@ GEM
json (>= 1.8, < 3)
simplecov-html (~> 0.10.0)
simplecov-html (0.10.2)
sprockets (3.7.1)
sprockets (3.7.2)
concurrent-ruby (~> 1.0)
rack (> 1, < 3)
sprockets-rails (3.2.1)
......@@ -342,7 +350,7 @@ GEM
tilt (2.0.8)
timecop (0.8.1)
truncate_html (0.9.3)
tzinfo (1.2.3)
tzinfo (1.2.5)
thread_safe (~> 0.1)
uglifier (3.2.0)
execjs (>= 0.3.0, < 3)
......@@ -357,10 +365,10 @@ GEM
crack (>= 0.3.2)
websocket-driver (0.6.5)
websocket-extensions (>= 0.1.0)
websocket-extensions (0.1.2)
websocket-extensions (0.1.3)
will_paginate (3.1.6)
xpath (2.1.0)
nokogiri (~> 1.3)
xpath (3.1.0)
nokogiri (~> 1.8)
PLATFORMS
ruby
......@@ -370,7 +378,7 @@ DEPENDENCIES
brakeman
byebug
capybara
capybara-webkit
capybara-webkit!
clipboard-rails
coffee-rails
compass-rails
......@@ -404,7 +412,7 @@ DEPENDENCIES
piwik_analytics!
prettyphoto-rails
puma
rails (= 5.1.4)
rails (= 5.1.6)
rdoc
rspec-rails
sass-rails
......
......@@ -97,8 +97,8 @@ feature "Manage events" do
within "section#content" do
expect(page).to have_content "Evénément modifié avec succès."
expect(page).to have_selector("h1", text: @event.title)
expect(page).to have_content "mardi 02 juillet 2013 09:00 "
expect(page).to have_content "mardi 02 juillet 2013 12:00 "
expect(page).to have_content "mardi 02 juillet 2013 09:00"
expect(page).to have_content "mardi 02 juillet 2013 12:00"
end
end
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment