Attention ! Gitlab fournissant maintenant nativement des certificats Let’s Encrypt aux domaines personnalisés des Gitlab Pages, nous avons coupé notre service qui le faisait automatiquement pour vous.

Il est impératif, pour que votre domaine personnalisé continue à avoir un certificat Let’s Encrypt à jour, d’activer la fonctionnalité native dans les paramètres de votre projet. Cette activation remplacera votre certificat actuel par un nouveau certificat Let’s Encrypt géré par Gitlab.

Voir les détails sur https://docs.framasoft.org/fr/gitlab/gitlab-pages-le.html

Commit 461bd5ae authored by Alexandre Friquet's avatar Alexandre Friquet

Upgrades rails to 4.2.9: refs #23.

parent 3e4c6376
......@@ -22,14 +22,14 @@
#
source 'https://rubygems.org'
gem 'rails', '4.1.16'
gem 'rails', '4.2.9'
gem 'sass-rails'
gem 'uglifier'
gem 'coffee-rails'
gem 'jquery-rails'
gem 'dotenv-rails'
gem "paperclip", '~> 3.5'
gem "paperclip"
gem "hirb"
gem "acts_as_list"
gem "pdfkit"
......@@ -85,4 +85,5 @@ group :development do
#gem 'mailcatcher'
gem 'brakeman'
gem 'puma'
gem 'web-console', '~> 2.0'
end
......@@ -29,40 +29,50 @@ GEM
remote: https://rubygems.org/
specs:
RedCloth (4.3.2)
actionmailer (4.1.16)
actionpack (= 4.1.16)
actionview (= 4.1.16)
actionmailer (4.2.9)
actionpack (= 4.2.9)
actionview (= 4.2.9)
activejob (= 4.2.9)
mail (~> 2.5, >= 2.5.4)
actionpack (4.1.16)
actionview (= 4.1.16)
activesupport (= 4.1.16)
rack (~> 1.5.2)
rails-dom-testing (~> 1.0, >= 1.0.5)
actionpack (4.2.9)
actionview (= 4.2.9)
activesupport (= 4.2.9)
rack (~> 1.6)
rack-test (~> 0.6.2)
actionview (4.1.16)
activesupport (= 4.1.16)
rails-dom-testing (~> 1.0, >= 1.0.5)
rails-html-sanitizer (~> 1.0, >= 1.0.2)
actionview (4.2.9)
activesupport (= 4.2.9)
builder (~> 3.1)
erubis (~> 2.7.0)
activemodel (4.1.16)
activesupport (= 4.1.16)
rails-dom-testing (~> 1.0, >= 1.0.5)
rails-html-sanitizer (~> 1.0, >= 1.0.3)
activejob (4.2.9)
activesupport (= 4.2.9)
globalid (>= 0.3.0)
activemodel (4.2.9)
activesupport (= 4.2.9)
builder (~> 3.1)
activerecord (4.1.16)
activemodel (= 4.1.16)
activesupport (= 4.1.16)
arel (~> 5.0.0)
activesupport (4.1.16)
i18n (~> 0.6, >= 0.6.9)
json (~> 1.7, >= 1.7.7)
activerecord (4.2.9)
activemodel (= 4.2.9)
activesupport (= 4.2.9)
arel (~> 6.0)
activesupport (4.2.9)
i18n (~> 0.7)
minitest (~> 5.1)
thread_safe (~> 0.1)
thread_safe (~> 0.3, >= 0.3.4)
tzinfo (~> 1.1)
acts_as_list (0.9.5)
activerecord (>= 3.0)
addressable (2.3.4)
arel (5.0.1.20140414130214)
arel (6.0.4)
autoparse (0.3.3)
addressable (>= 2.3.1)
extlib (>= 0.9.15)
multi_json (>= 1.0.0)
binding_of_caller (0.7.2)
debug_inspector (>= 0.0.1)
bluecloth (2.2.0)
brakeman (3.1.1)
erubis (~> 2.6)
......@@ -118,6 +128,7 @@ GEM
safe_yaml (~> 1.0.0)
daemons (1.1.9)
database_cleaner (1.4.0)
debug_inspector (0.0.3)
delayed_job (4.1.3)
activesupport (>= 3.0, < 5.2)
delayed_job_active_record (4.1.2)
......@@ -151,6 +162,8 @@ GEM
rspec-core (~> 3.0)
ruby-progressbar (~> 1.4)
geocoder (1.2.0)
globalid (0.4.0)
activesupport (>= 4.2.0)
gmaps4rails (2.1.2)
google-api-client (0.7.1)
addressable (>= 2.3.2)
......@@ -183,12 +196,15 @@ GEM
jwt (1.2.0)
launchy (2.3.0)
addressable (~> 2.3)
loofah (2.0.3)
nokogiri (>= 1.5.9)
mail (2.6.6)
mime-types (>= 1.16, < 4)
method_source (0.8.1)
mime-types (3.1)
mime-types-data (~> 3.2015)
mime-types-data (3.2016.0521)
mimemagic (0.3.2)
mini_portile2 (2.2.0)
minitest (5.10.3)
multi_json (1.12.2)
......@@ -196,11 +212,12 @@ GEM
nested_form (0.3.2)
nokogiri (1.8.0)
mini_portile2 (~> 2.2.0)
paperclip (3.5.4)
activemodel (>= 3.0.0)
activesupport (>= 3.0.0)
cocaine (~> 0.5.3)
paperclip (5.1.0)
activemodel (>= 4.2.0)
activesupport (>= 4.2.0)
cocaine (~> 0.5.5)
mime-types
mimemagic (~> 0.3.0)
pdfkit (0.6.2)
power_assert (1.0.2)
prettyphoto-rails (0.2.1)
......@@ -215,22 +232,31 @@ GEM
pry-rails (0.3.0)
pry (>= 0.9.10)
puma (3.1.0)
rack (1.5.5)
rack (1.6.8)
rack-test (0.6.3)
rack (>= 1.0)
rails (4.1.16)
actionmailer (= 4.1.16)
actionpack (= 4.1.16)
actionview (= 4.1.16)
activemodel (= 4.1.16)
activerecord (= 4.1.16)
activesupport (= 4.1.16)
rails (4.2.9)
actionmailer (= 4.2.9)
actionpack (= 4.2.9)
actionview (= 4.2.9)
activejob (= 4.2.9)
activemodel (= 4.2.9)
activerecord (= 4.2.9)
activesupport (= 4.2.9)
bundler (>= 1.3.0, < 2.0)
railties (= 4.1.16)
sprockets-rails (~> 2.0)
railties (4.1.16)
actionpack (= 4.1.16)
activesupport (= 4.1.16)
railties (= 4.2.9)
sprockets-rails
rails-deprecated_sanitizer (1.0.3)
activesupport (>= 4.2.0.alpha)
rails-dom-testing (1.0.8)
activesupport (>= 4.2.0.beta, < 5.0)
nokogiri (~> 1.6)
rails-deprecated_sanitizer (>= 1.0.1)
rails-html-sanitizer (1.0.3)
loofah (~> 2.0)
railties (4.2.9)
actionpack (= 4.2.9)
activesupport (= 4.2.9)
rake (>= 0.8.7)
thor (>= 0.18.1, < 2.0)
rake (12.1.0)
......@@ -319,6 +345,11 @@ GEM
execjs (>= 0.3.0, < 3)
uuidtools (2.1.5)
vcr (2.9.3)
web-console (2.3.0)
activemodel (>= 4.0)
binding_of_caller (>= 0.7.2)
railties (>= 4.0)
sprockets-rails (>= 2.0, < 4.0)
webmock (1.17.4)
addressable (>= 2.2.7)
crack (>= 0.3.2)
......@@ -361,13 +392,13 @@ DEPENDENCIES
jquery-ui-rails
launchy
nested_form
paperclip (~> 3.5)
paperclip
pdfkit
piwik_analytics!
prettyphoto-rails
pry-rails
puma
rails (= 4.1.16)
rails (= 4.2.9)
rdoc
rspec-rails (~> 3.5.0)
sass-rails
......@@ -381,6 +412,7 @@ DEPENDENCIES
truncate_html
uglifier
vcr (~> 2.9.3)
web-console (~> 2.0)
webmock (~> 1.17.4)
will_paginate
zeroclipboard-rails
......
......@@ -29,6 +29,7 @@ class Activity < ActiveRecord::Base
accepts_nested_attributes_for :attached_files, :allow_destroy => true
has_attached_file :poster, :styles => { :thumb => "20x20", :standard => "120x120" }, :convert_options => { :all => '-strip -colorspace RGB'}
validates_attachment_size :poster, :less_than => 1.megabyte, :message => "doit faire moins de 1 MB", :if => Proc.new { |file| !file.poster_file_name.blank? }
do_not_validate_attachment_file_type :poster
default_scope { order('title ASC') }
scope :filterable, -> { where(filterable: true) }
......
......@@ -26,6 +26,7 @@ class AttachedFile < ActiveRecord::Base
validates_attachment_presence :file, :message => " : est obligatoire!"
validates_attachment_size :file, :less_than => 9.megabyte, :message => " : doit être inférieur à 9 Mo"
do_not_validate_attachment_file_type :file
validates_presence_of :name
end
......@@ -28,6 +28,7 @@ class Image < ActiveRecord::Base
validates_attachment_presence :img_file, :message => " : est obligatoire!"
validates_attachment_size :img_file, :less_than => 5.megabyte, :message => " : doit être inférieur à 5 Mo"
do_not_validate_attachment_file_type :img_file
validates_presence_of :title
......
......@@ -24,6 +24,7 @@ class Logo < ActiveRecord::Base
belongs_to :page
has_attached_file :img, styles: { thumb: "100x86", midi: "330x248", maxi: "760x570"}, convert_options: { all: '-strip -colorspace RGB'}
validates_attachment_size :img, less_than: 1.megabyte, message: " : doit être inférieur à 1 Mo"
do_not_validate_attachment_file_type :img
scope :displayed, -> { where(displayed: true) }
end
......@@ -29,6 +29,7 @@ class Novel < ActiveRecord::Base
has_attached_file :picture, styles: { thumb: "120x120"}, convert_options: { all: '-strip -colorspace RGB'}
validates_presence_of :title, :content
do_not_validate_attachment_file_type :picture
# Scopes
default_scope { order('updated_at DESC') }
......
......@@ -24,6 +24,7 @@ class Partner < ActiveRecord::Base
belongs_to :website
belongs_to :group, class_name: "PartnersGroup"
has_attached_file :logo, :styles => { :thumb => "100x86", :standard => "160x120" }, :convert_options => { :all => '-strip -colorspace RGB'}
do_not_validate_attachment_file_type :logo
validates_attachment_size :logo, :less_than => 1.megabyte, :message => "doit faire moins de 1 Mo"
has_and_belongs_to_many :newsletters
......
......@@ -30,5 +30,7 @@ class Website < ActiveRecord::Base
validates :contact_email, email_format: true, allow_blank: true
validates_attachment_size :site_logo, :less_than => 1.megabyte, :message => "doit faire moins de 1 Mo", :if => Proc.new { |file| !file.site_logo_file_name.blank? }
do_not_validate_attachment_file_type :site_logo
validates_attachment_size :motto_logo, :less_than => 1.megabyte, :message => "doit faire moins de 1 Mo", :if => Proc.new { |file| !file.site_logo_file_name.blank? }
do_not_validate_attachment_file_type :motto_logo
end
......@@ -37,7 +37,7 @@ OLIGAA::Application.configure do
config.action_controller.perform_caching = true
# Disable Rails's static asset server (Apache or nginx will already do this)
config.serve_static_assets = false
config.serve_static_files = false
# Compress JavaScripts and CSS
config.assets.js_compressor = :uglifier
......@@ -61,9 +61,6 @@ OLIGAA::Application.configure do
# Force all access to the app over SSL, use Strict-Transport-Security, and use secure cookies.
# config.force_ssl = true
# See everything in the log (default is :info)
# config.log_level = :debug
# Prepend all log lines with the following tags
# config.log_tags = [ :subdomain, :uuid ]
......@@ -91,4 +88,5 @@ OLIGAA::Application.configure do
# Use default logging formatter so that PID and timestamp are not suppressed.
config.log_formatter = ::Logger::Formatter.new
config.log_level = :info
end
......@@ -30,7 +30,7 @@ OLIGAA::Application.configure do
config.cache_classes = true
# Configure static asset server for tests with Cache-Control for performance
config.serve_static_assets = true
config.serve_static_files = true
config.static_cache_control = "public, max-age=3600"
# Do not eager load code on boot. This avoids loading your whole application
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment