Commit 4f6eb945 authored by Bozosoft's avatar Bozosoft

Version 7.2.0 24/02/2016 - En cours

- Modification des fichiers .htaccess en conformité Apache 2.2 ou 2.4 avec la sélection par IfModule ....
- Correction sur la saisie du champ "Description du fichier" dans la page "Adhérents-Gestion fichier"
- Correction sur date "date_debannee_asso" dans install/data.sql
- Ajout du moyen de paiement par PayPal dans /config/lang.php dans tableau $T_PAIEMENT_COTIS 'pay'=>'Paypal',
- Mise à jour de Smarty à la version 3.1.29 datée du 21/12/2015
- Mise à jour de ADOdb à la version 5.20.3 datée du 01/01/2016
- Possibilité de choix des CSS de couleur marron (fichiers m_style_screen.css et m_style_print.css) à renommer en style_screen.css et style_print.css dans le dossier /js
- Correction du fichier de description des tables /doc/tables_description.rtf
parent 3820a247
<ifDefine Free>
PHP 1
</ifDefine>
# pour éviter les rep vides
Options -Indexes
\ No newline at end of file
Options -Indexes
# Dans la version Apache 2.4 mod_authz_host
# Dans la version Apache 2.2 mod_access_compat
<Files ~ "\.htaccess">
# Apache 2.4
<IfModule mod_authz_core.c>
Require all granted
</IfModule>
# Apache 2.2
<IfModule !mod_authz_core.c>
Order allow,deny
Deny from all
</IfModule>
</Files>
#
RedirectMatch 403 ^/.*\.htaccess$
RedirectMatch 403 ^.*/config/.*\.php$
RedirectMatch 403 ^.*/doc/.*\.php$
RedirectMatch 403 ^.*/fichiersadht/.*\.php$
RedirectMatch 403 ^.*/images/.*\.php$
RedirectMatch 403 ^.*/include/.*\.php$
RedirectMatch 403 ^.*/photos/.*\.php$
RedirectMatch 403 ^.*/tmp/.*\.php$
RedirectMatch 403 ^.*/templates/.*\.php$
......@@ -8,8 +8,8 @@
* ---------------------------
*
* @author : JC Etiemble - http://jc.etiemble.free.fr
* @version : 2014
* @copyright 2007-2014 (c) JC Etiemble
* @version : 2016
* @copyright 2007-2016 (c) JC Etiemble
* @package GestAssoPhp+Pg
*/
......@@ -120,7 +120,7 @@ if (($sessionadherent) && $log == ($_SESSION['ses_login_adht']) && $pas == ($_SE
$id_adht_file = get_post_variable_numeric('id_adht_file', '');// l'id de l'adhérent initial qui avait le fichier
if (($modification_fichier == 1) && $id_adht_modif ) {
$descript_fichier = get_post_variable('descript_fichier', '');//
$descript_fichier = addslashes(get_post_variable('descript_fichier', ''));//ajout addslashes 22/02/2016
$req_ecrit_modif_fichier = ("UPDATE ".TABLE_FICHIER_ADHERENTS
." SET id_adht_file='$id_adht_modif',"
." design_file_adht='$descript_fichier',datemodif_file_adht ='$date_du_jour' "
......@@ -265,4 +265,4 @@ if (($sessionadherent) && $log == ($_SESSION['ses_login_adht']) && $pas == ($_SE
}
?>
\ No newline at end of file
# Ce fichier htaccess.txt est a renommer en .htaccess APRES l'installation
# Empecher de lire ou accéder au fichier .htaccess
<files .htaccess>
order allow,deny
deny from all
</files>
# Empêcher de lire ou accéder au fichier .htaccess
# Voir le fichier .htaccess à la racine
# Empecher de lire ou accéder au fichier config.php
<Files connexion.cfg.php>
order allow,deny
deny from all
# Dans la version Apache 2.4 mod_authz_host
# Dans la version Apache 2.2 mod_access_compat
<Files ~ "connexion.cfg.php">
# Apache 2.4
<IfModule mod_authz_core.c>
Require all granted
</IfModule>
# Apache 2.2
<IfModule !mod_authz_core.c>
Order allow,deny
Deny from all
</IfModule>
</Files>
This diff is collapsed.
......@@ -8,8 +8,8 @@
* ---------------------------
*
* @author : JC Etiemble - http://jc.etiemble.free.fr
* @version : 2015
* @copyright 2007-2015 (c) JC Etiemble
* @version : 2016
* @copyright 2007-2016 (c) JC Etiemble
* @package GestAssoPhp+Pg
*/
......@@ -21,8 +21,8 @@
*/
/**** La version de GestAsssoPhp */
$VERSION = "GestAssoPhp+Pg V 7.1.2";
$VERSION = "GestAssoPhp+Pg V 7.2.0";
define('VERSION', $VERSION);
?>
\ No newline at end of file
?>
#Interdit affichage de tout~es mes extensions Files
<Files ~ "\.(txt|diff|php|php3|php4|php5|phtml|pl|cgi)$">
order deny,allow
deny from all
</Files>
#Interdit affichage de toutes mes extensions
# To deny PHPs
# Dans la version Apache 2.4 mod_authz_host
# Dans la version Apache 2.2 mod_access_compat
<FilesMatch "\.(php|php3|php4|php5|phtml|pl|cgi)$">
# Apache 2.4
<IfModule mod_authz_core.c>
Require all denied
</IfModule>
# Apache 2.2
<IfModule !mod_authz_core.c>
Order Allow,Deny
Deny from all
</IfModule>
</FilesMatch>
# Autorise affichage index.html
<Files index.html>
order deny,allow
#deny from all
</Files>
# Autorise affichage CCBY-SA-France.htm
<Files CCBY-SA-France.htm>
order deny,allow
#deny from all
</Files>
\ No newline at end of file
......@@ -7,20 +7,34 @@
* ---------------------------
*
* @author : JC Etiemble - http://jc.etiemble.free.fr
* @version : 2015
* @copyright 2007-2015 (c) JC Etiemble
* @version : 2016
* @copyright 2007-2016 (c) JC Etiemble
* @package GestAssoPhp+Pg
*/
Version 7.1.2 03/12/2015 - Finale
Version 7.2.0 24/02/2016 - En cours
-----------------------
- Modification des fichiers .htaccess en conformité Apache 2.2 ou 2.4 avec la sélection par IfModule ....
- Correction sur la saisie du champ "Description du fichier" dans la page "Adhérents-Gestion fichier"
- Correction sur date "date_debannee_asso" dans install/data.sql
- Ajout du moyen de paiement par PayPal dans /config/lang.php dans tableau $T_PAIEMENT_COTIS 'pay'=>'Paypal',
- Mise à jour de Smarty à la version 3.1.29 datée du 21/12/2015
- Mise à jour de ADOdb à la version 5.20.3 datée du 01/01/2016
- Possibilité de choix des CSS de couleur marron (fichiers m_style_screen.css et m_style_print.css) à renommer en style_screen.css et style_print.css dans le dossier /js
- Correction du fichier de description des tables /doc/tables_description.rtf
Version 7.1.2 03/12/2015 - Finale
-----------------------
- Compatiblité PHP 7.0
- Mise à jour de adodb en V5.20 dev (PHP 7)
- Mise à jour de Smarty 3.1.27 (datée du 19/06/2015)
- Installation : par défaut MySQLi en remplacement de MySQL
- Installation : jma_fin_cotis = 31/12/2016 dans data.sql
Version 7.1.0 01/06/2015 - En développement
Version 7.1.0 01/06/2015 -
- Mise à jour de Smarty 3.1.24 (23/05/2015) https://github.com/smarty-php/smarty
- Mise à jour de adodb en V5.19 23-Apr-2014 https://github.com/ADOdb/ADOdb
- Correction sur export_tadhts.php (champ18) et export_tcotis.php (champ3 et 11) 08/05/2015
......
This diff is collapsed.
# To deny PHPs + js
<Files ~ "\.(php|php3|php4|php5|phtml|pl|cgi|js)$">
order deny,allow
deny from all
</Files>
\ No newline at end of file
#Interdit affichage de toutes mes extensions + js
# To deny PHPs
# Dans la version Apache 2.4 mod_authz_host
# Dans la version Apache 2.2 mod_access_compat
<FilesMatch "\.(php|php3|php4|php5|phtml|pl|cgi|js)$">
# Apache 2.4
<IfModule mod_authz_core.c>
Require all denied
</IfModule>
# Apache 2.2
<IfModule !mod_authz_core.c>
Order Allow,Deny
Deny from all
</IfModule>
</FilesMatch>
# To deny PHPs + js
<Files ~ "\.(php|php3|php4|php5|phtml|pl|cgi|js)$">
order deny,allow
deny from all
</Files>
#Interdit affichage de toutes mes extensions + js
# To deny PHPs
# Dans la version Apache 2.4 mod_authz_host
# Dans la version Apache 2.2 mod_access_compat
<FilesMatch "\.(php|php3|php4|php5|phtml|pl|cgi|js)$">
# Apache 2.4
<IfModule mod_authz_core.c>
Require all denied
</IfModule>
# Apache 2.2
<IfModule !mod_authz_core.c>
Order Allow,Deny
Deny from all
</IfModule>
</FilesMatch>
# To deny PHPs + js
<Files ~ "\.(php|php3|php4|php5|phtml|pl|cgi|js)$">
order deny,allow
deny from all
</Files>
#Interdit affichage de toutes mes extensions + js
# To deny PHPs
# Dans la version Apache 2.4 mod_authz_host
# Dans la version Apache 2.2 mod_access_compat
<FilesMatch "\.(php|php3|php4|php5|phtml|pl|cgi|js)$">
# Apache 2.4
<IfModule mod_authz_core.c>
Require all denied
</IfModule>
# Apache 2.2
<IfModule !mod_authz_core.c>
Order Allow,Deny
Deny from all
</IfModule>
</FilesMatch>
# To deny PHPs + js
<Files ~ "\.(php|php3|php4|php5|phtml|pl|cgi|js)$">
order deny,allow
deny from all
</Files>
#Interdit affichage de toutes mes extensions + js
# To deny PHPs
# Dans la version Apache 2.4 mod_authz_host
# Dans la version Apache 2.2 mod_access_compat
<FilesMatch "\.(php|php3|php4|php5|phtml|pl|cgi|js)$">
# Apache 2.4
<IfModule mod_authz_core.c>
Require all denied
</IfModule>
# Apache 2.2
<IfModule !mod_authz_core.c>
Order Allow,Deny
Deny from all
</IfModule>
</FilesMatch>
# To deny PHPs + js
<Files ~ "\.(php|php3|php4|php5|phtml|pl|cgi|js)$">
order deny,allow
deny from all
</Files>
#Interdit affichage de toutes mes extensions + js
# To deny PHPs
# Dans la version Apache 2.4 mod_authz_host
# Dans la version Apache 2.2 mod_access_compat
<FilesMatch "\.(php|php3|php4|php5|phtml|pl|cgi|js)$">
# Apache 2.4
<IfModule mod_authz_core.c>
Require all denied
</IfModule>
# Apache 2.2
<IfModule !mod_authz_core.c>
Order Allow,Deny
Deny from all
</IfModule>
</FilesMatch>
# To deny PHPs + js
<Files ~ "\.(php|php3|php4|php5|phtml|pl|cgi|js)$">
order deny,allow
deny from all
</Files>
#Interdit affichage de toutes mes extensions + js
# To deny PHPs
# Dans la version Apache 2.4 mod_authz_host
# Dans la version Apache 2.2 mod_access_compat
<FilesMatch "\.(php|php3|php4|php5|phtml|pl|cgi|js)$">
# Apache 2.4
<IfModule mod_authz_core.c>
Require all denied
</IfModule>
# Apache 2.2
<IfModule !mod_authz_core.c>
Order Allow,Deny
Deny from all
</IfModule>
</FilesMatch>
# To deny PHPs + js
<Files ~ "\.(php|php3|php4|php5|phtml|pl|cgi|js)$">
order deny,allow
deny from all
</Files>
#Interdit affichage de toutes mes extensions + js
# To deny PHPs
# Dans la version Apache 2.4 mod_authz_host
# Dans la version Apache 2.2 mod_access_compat
<FilesMatch "\.(php|php3|php4|php5|phtml|pl|cgi|js)$">
# Apache 2.4
<IfModule mod_authz_core.c>
Require all denied
</IfModule>
# Apache 2.2
<IfModule !mod_authz_core.c>
Order Allow,Deny
Deny from all
</IfModule>
</FilesMatch>
deny from all
\ No newline at end of file
# Dans la version Apache 2.4 mod_authz_host
# Dans la version Apache 2.2 mod_access_compat
# Apache 2.4
<IfModule mod_authz_core.c>
Require all denied
</IfModule>
# Apache 2.2
<IfModule !mod_authz_core.c>
Order Allow,Deny
Deny from all
</IfModule>
......@@ -19,7 +19,7 @@ INSERT INTO gs_types_cotisations (nom_type_cotisation, montant_cotisation) VALUE
INSERT INTO gs_preference_asso (id_pref, design_pref, val_pref) VALUES
(1, 'messagetitre', '- SITE DE TEST POUR DEMONSTRATION -'),
(2, 'nom_asso_gestassophp', 'Mon Asso simple sur le WEB'),
(3, 'date_debannee_asso', '2013'),
(3, 'date_debannee_asso', '2016'),
(4, 'nb_lignes_page', '20'),
(5, 'email_adresse', 'jc.e@moi.com'),
(6, 'adherent_bene', 'Utilisateur'),
......
# To deny PHPs + js
<Files ~ "\.(php|php3|php4|php5|phtml|pl|cgi|js)$">
order deny,allow
deny from all
</Files>
\ No newline at end of file
#Interdit affichage de toutes mes extensions + js
# To deny PHPs
# Dans la version Apache 2.4 mod_authz_host
# Dans la version Apache 2.2 mod_access_compat
<FilesMatch "\.(php|php3|php4|php5|phtml|pl|cgi|js)$">
# Apache 2.4
<IfModule mod_authz_core.c>
Require all denied
</IfModule>
# Apache 2.2
<IfModule !mod_authz_core.c>
Order Allow,Deny
Deny from all
</IfModule>
</FilesMatch>
# -------------------
<Files Changelog.txt>
order allow,deny
deny from all
</Files>
<Files lisez_moi.txt>
order allow,deny
deny from all
</Files>
\ No newline at end of file
deny from all
\ No newline at end of file
# Dans la version Apache 2.4 mod_authz_host
# Dans la version Apache 2.2 mod_access_compat
# Apache 2.4
<IfModule mod_authz_core.c>
Require all denied
</IfModule>
# Apache 2.2
<IfModule !mod_authz_core.c>
Order Allow,Deny
Deny from all
</IfModule>
deny from all
\ No newline at end of file
# Dans la version Apache 2.4 mod_authz_host
# Dans la version Apache 2.2 mod_access_compat
# Apache 2.4
<IfModule mod_authz_core.c>
Require all denied
</IfModule>
# Apache 2.2
<IfModule !mod_authz_core.c>
Order Allow,Deny
Deny from all
</IfModule>
deny from all
\ No newline at end of file
# Dans la version Apache 2.4 mod_authz_host
# Dans la version Apache 2.2 mod_access_compat
# Apache 2.4
<IfModule mod_authz_core.c>
Require all denied
</IfModule>
# Apache 2.2
<IfModule !mod_authz_core.c>
Order Allow,Deny
Deny from all
</IfModule>
......@@ -8,7 +8,7 @@ $ADODB_INCLUDED_CSV = 1;
/*
@version v5.21dev ??-???-2015
@version v5.20.3 01-Jan-2016
@copyright (c) 2000-2013 John Lim (jlim#natsoft.com). All rights reserved.
@copyright (c) 2014 Damien Regad, Mark Newnham and the ADOdb community
Released under both BSD license and Lesser GPL library license.
......
<?php
/**
@version v5.21dev ??-???-2015
@version v5.20.3 01-Jan-2016
@copyright (c) 2000-2013 John Lim (jlim#natsoft.com). All rights reserved.
@copyright (c) 2014 Damien Regad, Mark Newnham and the ADOdb community
Released under both BSD license and Lesser GPL library license.
......
<?php
/**
* @version v5.21dev ??-???-2015
* @version v5.20.3 01-Jan-2016
* @copyright (c) 2000-2013 John Lim (jlim#natsoft.com). All rights reserved.
* @copyright (c) 2014 Damien Regad, Mark Newnham and the ADOdb community
* Released under both BSD license and Lesser GPL library license.
......
<?php
/**
* @version v5.21dev ??-???-2015
* @version v5.20.3 01-Jan-2016
* @copyright (c) 2000-2013 John Lim (jlim#natsoft.com). All rights reserved.
* @copyright (c) 2014 Damien Regad, Mark Newnham and the ADOdb community
* Released under both BSD license and Lesser GPL library license.
......
<?php
/**
* @version v5.21dev ??-???-2015
* @version v5.20.3 01-Jan-2016
* @copyright (c) 2000-2013 John Lim (jlim#natsoft.com). All rights reserved.
* @copyright (c) 2014 Damien Regad, Mark Newnham and the ADOdb community
* Released under both BSD license and Lesser GPL library license.
......
<?php
/*
@version v5.21dev ??-???-2015
@version v5.20.3 01-Jan-2016
@copyright (c) 2000-2013 John Lim (jlim#natsoft.com). All rights reserved.
@copyright (c) 2014 Damien Regad, Mark Newnham and the ADOdb community
Released under both BSD license and Lesser GPL library license.
......
......@@ -6,7 +6,7 @@ global $ADODB_INCLUDED_LIB;
$ADODB_INCLUDED_LIB = 1;
/*
@version v5.21dev ??-???-2015
@version v5.20.3 01-Jan-2016
@copyright (c) 2000-2013 John Lim (jlim#natsoft.com). All rights reserved.
@copyright (c) 2014 Damien Regad, Mark Newnham and the ADOdb community
Released under both BSD license and Lesser GPL library license.
......
......@@ -3,7 +3,7 @@
ADOdb Date Library, part of the ADOdb abstraction library
Download: http://adodb.sourceforge.net/#download
@version v5.21dev ??-???-2015
@version v5.20.3 01-Jan-2016
@copyright (c) 2000-2013 John Lim (jlim#natsoft.com). All rights reserved.
@copyright (c) 2014 Damien Regad, Mark Newnham and the ADOdb community
......
......@@ -14,7 +14,7 @@
/**
\mainpage
@version v5.21dev ??-???-2015
@version v5.20.3 01-Jan-2016
@copyright (c) 2000-2013 John Lim (jlim#natsoft.com). All rights reserved.
@copyright (c) 2014 Damien Regad, Mark Newnham and the ADOdb community
......@@ -217,7 +217,7 @@ if (!defined('_ADODB_LAYER')) {
/**
* ADODB version as a string.
*/
$ADODB_vers = 'v5.21dev ??-???-2015';
$ADODB_vers = 'v5.20.3 01-Jan-2016';
/**
* Determines whether recordset->RecordCount() is used.
......@@ -535,12 +535,21 @@ if (!defined('_ADODB_LAYER')) {
static function Version() {
global $ADODB_vers;
$ok = preg_match( '/^[Vv]?([0-9]\.[0-9]+(dev|[a-z])?)/', $ADODB_vers, $matches );
if (!$ok) {
return (float) substr($ADODB_vers,1);
} else {
return $matches[1];
// Semantic Version number matching regex
$regex = '^[vV]?(\d+\.\d+\.\d+' // Version number (X.Y.Z) with optional 'V'
. '(?:-(?:' // Optional preprod version: a '-'
. 'dev|' // followed by 'dev'
. '(?:(?:alpha|beta|rc)(?:\.\d+))' // or a preprod suffix and version number
. '))?)(?:\s|$)'; // Whitespace or end of string
if (!preg_match("/$regex/", $ADODB_vers, $matches)) {
// This should normally not happen... Return whatever is between the start
// of the string and the first whitespace (or the end of the string).
self::outp("Invalid version number: '$ADODB_vers'", 'Version');
$regex = '^[vV]?(.*?)(?:\s|$)';
preg_match("/$regex/", $ADODB_vers, $matches);
}
return $matches[1];
}
/**
......@@ -3433,6 +3442,11 @@ http://www.stanford.edu/dept/itss/docs/oracle/10g/server.101/b10759/statements_1
return false;
}
// Empty recordset
if (!$this->fields) {
return array();
}
// Determine whether the array is associative or 0-based numeric
$numIndex = array_keys($this->fields) == range(0, count($this->fields) - 1);
......
This diff is collapsed.
......@@ -6,7 +6,21 @@ Older changelogs:
[v2.x](changelog_v2.x.md).
## 5.21 - ??-???-2015
## 5.20.3 - 01-Jan-2016
- mssql: PHP warning when closing recordset from destructor not fixed in v5.20.2. #180
## 5.20.2 - 27-Dec-2015
- adodb: Remove a couple leftover PHP 4.x constructors (PHP7 compatibility). #139
- mysql: MoveNext() now respects ADODB_ASSOC_CASE. #167
- mssql, mysql, informix: Avoid PHP warning when closing recordset from destructor. #170
## 5.20.1 - 06-Dec-2015
- adodb: Fix regression introduced in 5.20.0, causing a PHP Warning when
calling GetAssoc() on an empty recordset. See Github #162
- ADOConnection::Version() now handles SemVer. See Github #164
## 5.20.0 - 28-Nov-2015
......
<?php
/**
@version v5.21dev ??-???-2015
@version v5.20.3 01-Jan-2016
@copyright (c) 2000-2013 John Lim (jlim#natsoft.com). All rights reserved.
@copyright (c) 2014 Damien Regad, Mark Newnham and the ADOdb community
Released under both BSD license and Lesser GPL library license.
......
<?php
/**
@version v5.21dev ??-???-2015
@version v5.20.3 01-Jan-2016
@copyright (c) 2000-2013 John Lim (jlim#natsoft.com). All rights reserved.
@copyright (c) 2014 Damien Regad, Mark Newnham and the ADOdb community
Released under both BSD license and Lesser GPL library license.
......
<?php
/*
@version v5.21dev ??-???-2015
@version v5.20.3 01-Jan-2016
@copyright (c) 2000-2013 John Lim (jlim#natsoft.com). All rights reserved.
@copyright (c) 2014 Damien Regad, Mark Newnham and the ADOdb community
Released under both BSD license and Lesser GPL library license.
......@@ -797,6 +797,7 @@ class ADORecordSet_mysql extends ADORecordSet{
//return adodb_movenext($this);
//if (defined('ADODB_EXTENSION')) return adodb_movenext($this);
if (@$this->fields = mysql_fetch_array($this->_queryID,$this->fetchMode)) {
$this->_updatefields();
$this->_currentRow += 1;
return true;
}
......
<?php
/*
@version v5.21dev ??-???-2015
@version v5.20.3 01-Jan-2016
@copyright (c) 2000-2013 John Lim (jlim#natsoft.com). All rights reserved.
@copyright (c) 2014 Damien Regad, Mark Newnham and the ADOdb community
Released under both BSD license and Lesser GPL library license.
......@@ -1033,7 +1033,10 @@ class ADORecordSet_mysqli extends ADORecordSet{
$this->_currentRow++;
$this->fields = @mysqli_fetch_array($this->_queryID,$this->fetchMode);
if (is_array($this->fields)) return true;
if (is_array($this->fields)) {
$this->_updatefields();
return true;
}
$this->EOF = true;
return false;
}
......@@ -1050,11 +1053,15 @@ class ADORecordSet_mysqli extends ADORecordSet{
//if results are attached to this pointer from Stored Proceedure calls, the next standard query will die 2014
//only a problem with persistant connections
while(mysqli_more_results($this->connection->_connectionID)){
@mysqli_next_result($this->connection->_connectionID);
if($this->connection->_connectionID) {
while(mysqli_more_results($this->connection->_connectionID)){
mysqli_next_result($this->connection->_connectionID);
}
}
@mysqli_free_result($this->_queryID);
if($this->_queryID) {
mysqli_free_result($this->_queryID);
}
$this->_queryID = false;
}
......
<?php
/*
@version v5.21dev ??-???-2015
@version v5.20.3 01-Jan-2016