• `TASK [peertube : install peertube] ********************************************************************************************************************************************************************************************** [WARNING]: Module remote_tmp /var/www/peertube/.ansible/tmp did not exist and was created with a mode of 0700, this may cause issues when running as another user. To avoid this, create the remote_tmp dir with the correct permissions manually

    fatal: [peertube.lusis.eu]: FAILED! => { "changed": true, "cmd": "cd "/var/www/peertube/peertube-latest" && yarn install "--production --pure-lockfile"", "delta": "0:01:50.908638", "end": "2020-10-22 14:20:24.729616", "rc": 127, "start": "2020-10-22 14:18:33.820978" }

    STDOUT:

    yarn install v1.22.5 [1/5] Validating package.json... [2/5] Resolving packages... [3/5] Fetching packages... info fsevents@2.1.3: The platform "linux" is incompatible with this module. info "fsevents@2.1.3" is an optional dependency and failed compatibility check. Excluding it from installation. [4/5] Linking dependencies... [5/5] Building fresh packages... $ test -n "$NOCLIENT" || (cd client && yarn install --pure-lockfile) yarn install v1.22.5 [1/4] Resolving packages... [2/4] Fetching packages... info fsevents@2.1.3: The platform "linux" is incompatible with this module. info "fsevents@2.1.3" is an optional dependency and failed compatibility check. Excluding it from installation. info fsevents@1.2.13: The platform "linux" is incompatible with this module. info "fsevents@1.2.13" is an optional dependency and failed compatibility check. Excluding it from installation. [3/4] Linking dependencies... [4/4] Building fresh packages... $ npm rebuild node-sass info Visit https://yarnpkg.com/en/docs/cli/install for documentation about this command. info Visit https://yarnpkg.com/en/docs/cli/install for documentation about this command.

    STDERR:

    warning Resolution field "http-signature@1.3.4" is incompatible with requested version "http-signature@~1.2.0" warning Resolution field "oauth2-server@3.1.0-beta.1" is incompatible with requested version "oauth2-server@3.0.0" warning " > @typescript-eslint/eslint-plugin@3.10.0" has unmet peer dependency "@typescript-eslint/parser@^3.0.0". warning " > marked-man@0.7.0" has incorrect peer dependency "marked@^0.7.0". warning " > file-loader@6.0.0" has unmet peer dependency "webpack@^4.0.0 || ^5.0.0". warning " > raw-loader@4.0.1" has unmet peer dependency "webpack@^4.0.0 || ^5.0.0". warning " > @ngx-i18nsupport/tooling@8.0.3" has incorrect peer dependency "@angular/common@^8.0.0". warning " > @ngx-i18nsupport/tooling@8.0.3" has incorrect peer dependency "@angular/core@^8.0.0". warning " > @ngx-loading-bar/http-client@5.1.0" has incorrect peer dependency "tslib@^1.10.0". warning " > @ngx-loading-bar/router@5.1.0" has incorrect peer dependency "tslib@^1.10.0". warning " > @ngx-meta/core@9.0.0" has incorrect peer dependency "@angular/core@>=9.0.0 <10.0.0". warning " > @ngx-meta/core@9.0.0" has incorrect peer dependency "@angular/platform-browser@>=9.0.0 <10.0.0". warning " > @ngx-meta/core@9.0.0" has incorrect peer dependency "@angular/platform-browser-dynamic@>=9.0.0 <10.0.0". warning " > @ngx-meta/core@9.0.0" has incorrect peer dependency "@angular/router@>=9.0.0 <10.0.0". warning " > @ngx-meta/core@9.0.0" has incorrect peer dependency "tslib@^1.10.0". warning " > angular2-hotkeys@2.2.0" has incorrect peer dependency "@angular/core@^5.2.0 || ^6.0.0 || ^7.0.0 || ^8.0.0 || ^9.0.0". warning " > angular2-hotkeys@2.2.0" has incorrect peer dependency "tslib@^1.10.0". warning " > bootstrap@4.5.2" has unmet peer dependency "jquery@1.9.1 - 3". warning " > bootstrap@4.5.2" has unmet peer dependency "popper.js@^1.16.1". warning " > css-loader@3.6.0" has unmet peer dependency "webpack@^4.0.0 || ^5.0.0". warning " > extract-text-webpack-plugin@4.0.0-beta.0" has unmet peer dependency "webpack@^3.0.0 || ^4.0.0". warning " > html-loader@1.2.1" has unmet peer dependency "webpack@^4.0.0 || ^5.0.0". warning " > html-webpack-plugin@4.3.0" has unmet peer dependency "webpack@>=4.0.0 < 6.0.0". warning " > linkifyjs@2.1.9" has unmet peer dependency "jquery@>= 1.11.0". warning " > linkifyjs@2.1.9" has unmet peer dependency "react@>= 0.14.0". warning " > linkifyjs@2.1.9" has unmet peer dependency "react-dom@>= 0.14.0". warning " > primeng@9.1.3" has incorrect peer dependency "@angular/core@^7.0.0 || ^8.0.0 || ^9.0.0". warning " > primeng@9.1.3" has incorrect peer dependency "@angular/common@^7.0.0 || ^8.0.0 || ^9.0.0". warning " > primeng@9.1.3" has incorrect peer dependency "@angular/forms@^7.0.0 || ^8.0.0 || ^9.0.0". warning " > sass-loader@8.0.2" has unmet peer dependency "webpack@^4.36.0 || ^5.0.0". warning "sass-resources-loader > @babel/cli@7.10.5" has unmet peer dependency "@babel/core@^7.0.0-0". warning "sass-resources-loader > babel-eslint@10.1.0" has unmet peer dependency "eslint@>= 4.12.1". warning " > terser-webpack-plugin@3.1.0" has unmet peer dependency "webpack@^4.0.0 || ^5.0.0". warning "tslint-config-standard > tslint-eslint-rules@5.4.0" has incorrect peer dependency "tslint@^5.0.0". warning " > webpack-cli@3.3.12" has unmet peer dependency "webpack@4.x.x". /bin/sh: 1: npm: not found error Command failed with exit code 127. error Command failed with exit code 127.

    MSG:

    non-zero return code

    to retry, use: --limit @/home/mark/mypeertube/play/peertube.retry

    PLAY RECAP ********************************************************************************************************************************************************************************************************************** peertube.lusis.eu : ok=25 changed=16 unreachable=0 failed=1
    `

    Edited by Mark Van den Borre
  • TASK [peertube : install peertube] **********************************************************************************************************************************************************************************************
     [WARNING]: Module remote_tmp /var/www/peertube/.ansible/tmp did not exist and was created with a mode of 0700, this may cause issues when running as another user. To avoid this, create the remote_tmp dir with the correct
    permissions manually
    
    fatal: [peertube.lusis.eu]: FAILED! => {
        "changed": true,
        "cmd": "cd \"/var/www/peertube/peertube-latest\" && yarn install \"--production --pure-lockfile\"",
        "delta": "0:01:50.908638",
        "end": "2020-10-22 14:20:24.729616",
        "rc": 127,
        "start": "2020-10-22 14:18:33.820978"
    }
    
    STDOUT:
    
    yarn install v1.22.5
    [1/5] Validating package.json...
    [2/5] Resolving packages...
    [3/5] Fetching packages...
    info fsevents@2.1.3: The platform "linux" is incompatible with this module.
    info "fsevents@2.1.3" is an optional dependency and failed compatibility check. Excluding it from installation.
    [4/5] Linking dependencies...
    [5/5] Building fresh packages...
    $ test -n "$NOCLIENT" || (cd client && yarn install --pure-lockfile)
    yarn install v1.22.5
    [1/4] Resolving packages...
    [2/4] Fetching packages...
    info fsevents@2.1.3: The platform "linux" is incompatible with this module.
    info "fsevents@2.1.3" is an optional dependency and failed compatibility check. Excluding it from installation.
    info fsevents@1.2.13: The platform "linux" is incompatible with this module.
    info "fsevents@1.2.13" is an optional dependency and failed compatibility check. Excluding it from installation.
    [3/4] Linking dependencies...
    [4/4] Building fresh packages...
    $ npm rebuild node-sass
    info Visit https://yarnpkg.com/en/docs/cli/install for documentation about this command.
    info Visit https://yarnpkg.com/en/docs/cli/install for documentation about this command.
    
    
    STDERR:
    
    warning Resolution field "http-signature@1.3.4" is incompatible with requested version "http-signature@~1.2.0"
    warning Resolution field "oauth2-server@3.1.0-beta.1" is incompatible with requested version "oauth2-server@3.0.0"
    warning " > @typescript-eslint/eslint-plugin@3.10.0" has unmet peer dependency "@typescript-eslint/parser@^3.0.0".
    warning " > marked-man@0.7.0" has incorrect peer dependency "marked@^0.7.0".
    warning " > file-loader@6.0.0" has unmet peer dependency "webpack@^4.0.0 || ^5.0.0".
    warning " > raw-loader@4.0.1" has unmet peer dependency "webpack@^4.0.0 || ^5.0.0".
    warning " > @ngx-i18nsupport/tooling@8.0.3" has incorrect peer dependency "@angular/common@^8.0.0".
    warning " > @ngx-i18nsupport/tooling@8.0.3" has incorrect peer dependency "@angular/core@^8.0.0".
    warning " > @ngx-loading-bar/http-client@5.1.0" has incorrect peer dependency "tslib@^1.10.0".
    warning " > @ngx-loading-bar/router@5.1.0" has incorrect peer dependency "tslib@^1.10.0".
    warning " > @ngx-meta/core@9.0.0" has incorrect peer dependency "@angular/core@>=9.0.0 <10.0.0".
    warning " > @ngx-meta/core@9.0.0" has incorrect peer dependency "@angular/platform-browser@>=9.0.0 <10.0.0".
    warning " > @ngx-meta/core@9.0.0" has incorrect peer dependency "@angular/platform-browser-dynamic@>=9.0.0 <10.0.0".
    warning " > @ngx-meta/core@9.0.0" has incorrect peer dependency "@angular/router@>=9.0.0 <10.0.0".
    warning " > @ngx-meta/core@9.0.0" has incorrect peer dependency "tslib@^1.10.0".
    warning " > angular2-hotkeys@2.2.0" has incorrect peer dependency "@angular/core@^5.2.0 || ^6.0.0 || ^7.0.0 || ^8.0.0 || ^9.0.0".
    warning " > angular2-hotkeys@2.2.0" has incorrect peer dependency "tslib@^1.10.0".
    warning " > bootstrap@4.5.2" has unmet peer dependency "jquery@1.9.1 - 3".
    warning " > bootstrap@4.5.2" has unmet peer dependency "popper.js@^1.16.1".
    warning " > css-loader@3.6.0" has unmet peer dependency "webpack@^4.0.0 || ^5.0.0".
    warning " > extract-text-webpack-plugin@4.0.0-beta.0" has unmet peer dependency "webpack@^3.0.0 || ^4.0.0".
    warning " > html-loader@1.2.1" has unmet peer dependency "webpack@^4.0.0 || ^5.0.0".
    warning " > html-webpack-plugin@4.3.0" has unmet peer dependency "webpack@>=4.0.0 < 6.0.0".
    warning " > linkifyjs@2.1.9" has unmet peer dependency "jquery@>= 1.11.0".
    warning " > linkifyjs@2.1.9" has unmet peer dependency "react@>= 0.14.0".
    warning " > linkifyjs@2.1.9" has unmet peer dependency "react-dom@>= 0.14.0".
    warning " > primeng@9.1.3" has incorrect peer dependency "@angular/core@^7.0.0 || ^8.0.0 || ^9.0.0".
    warning " > primeng@9.1.3" has incorrect peer dependency "@angular/common@^7.0.0 || ^8.0.0 || ^9.0.0".
    warning " > primeng@9.1.3" has incorrect peer dependency "@angular/forms@^7.0.0 || ^8.0.0 || ^9.0.0".
    warning " > sass-loader@8.0.2" has unmet peer dependency "webpack@^4.36.0 || ^5.0.0".
    warning "sass-resources-loader > @babel/cli@7.10.5" has unmet peer dependency "@babel/core@^7.0.0-0".
    warning "sass-resources-loader > babel-eslint@10.1.0" has unmet peer dependency "eslint@>= 4.12.1".
    warning " > terser-webpack-plugin@3.1.0" has unmet peer dependency "webpack@^4.0.0 || ^5.0.0".
    warning "tslint-config-standard > tslint-eslint-rules@5.4.0" has incorrect peer dependency "tslint@^5.0.0".
    warning " > webpack-cli@3.3.12" has unmet peer dependency "webpack@4.x.x".
    /bin/sh: 1: npm: not found
    error Command failed with exit code 127.
    error Command failed with exit code 127.
    
    
    MSG:
    
    non-zero return code
    
    	to retry, use: --limit @/home/mark/mypeertube/play/peertube.retry
    
    PLAY RECAP **********************************************************************************************************************************************************************************************************************
    peertube.lusis.eu          : ok=25   changed=16   unreachable=0    failed=1   
    
  • I cleaned up the node.js requirements, and I ended up with error messages in /var/log/syslog pointing me at more info in /var/www/peertube/.npm/_logs. Any hints?

    root@peertube:/var/www/peertube/.npm/_logs# cat 2020-10-22T15_49_52_163Z-debug.log 
    0 info it worked if it ends with ok
    1 verbose cli [ '/usr/bin/node', '/usr/bin/npm', 'start' ]
    2 info using npm@6.14.8
    3 info using node@v12.19.0
    4 verbose run-script [ 'prestart', 'start', 'poststart' ]
    5 info lifecycle peertube@2.4.0~prestart: peertube@2.4.0
    6 info lifecycle peertube@2.4.0~start: peertube@2.4.0
    7 verbose lifecycle peertube@2.4.0~start: unsafe-perm in lifecycle true
    8 verbose lifecycle peertube@2.4.0~start: PATH: /usr/lib/node_modules/npm/node_modules/npm-lifecycle/node-gyp-bin:/var/www/peertube/versions/peertube-v2.4.0/node_modules/.bin:/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin
    9 verbose lifecycle peertube@2.4.0~start: CWD: /var/www/peertube/versions/peertube-v2.4.0
    10 silly lifecycle peertube@2.4.0~start: Args: [ '-c', 'node dist/server' ]
    11 silly lifecycle peertube@2.4.0~start: Returned: code: 255  signal: null
    12 info lifecycle peertube@2.4.0~start: Failed to exec start script
    13 verbose stack Error: peertube@2.4.0 start: `node dist/server`
    13 verbose stack Exit status 255
    13 verbose stack     at EventEmitter.<anonymous> (/usr/lib/node_modules/npm/node_modules/npm-lifecycle/index.js:332:16)
    13 verbose stack     at EventEmitter.emit (events.js:314:20)
    13 verbose stack     at ChildProcess.<anonymous> (/usr/lib/node_modules/npm/node_modules/npm-lifecycle/lib/spawn.js:55:14)
    13 verbose stack     at ChildProcess.emit (events.js:314:20)
    13 verbose stack     at maybeClose (internal/child_process.js:1021:16)
    13 verbose stack     at Process.ChildProcess._handle.onexit (internal/child_process.js:286:5)
    14 verbose pkgid peertube@2.4.0
    15 verbose cwd /var/www/peertube/versions/peertube-v2.4.0
    16 verbose Linux 4.19.0-10-amd64
    17 verbose argv "/usr/bin/node" "/usr/bin/npm" "start"
    18 verbose node v12.19.0
    19 verbose npm  v6.14.8
    20 error code ELIFECYCLE
    21 error errno 255
    22 error peertube@2.4.0 start: `node dist/server`
    22 error Exit status 255
    23 error Failed at the peertube@2.4.0 start script.
    23 error This is probably not a problem with npm. There is likely additional logging output above.
    24 verbose exit [ 255, true ]
  • When I manually run yarn install, this happens:

    root@peertube:/var/www/peertube/peertube-latest# yarn install --production --pure-lockfile
    yarn install v1.22.5
    [1/5] Validating package.json...
    [2/5] Resolving packages...
    warning Resolution field "http-signature@1.3.4" is incompatible with requested version "http-signature@~1.2.0"
    warning Resolution field "oauth2-server@3.1.0-beta.1" is incompatible with requested version "oauth2-server@3.0.0"
    [3/5] Fetching packages...
    info fsevents@2.1.3: The platform "linux" is incompatible with this module.
    info "fsevents@2.1.3" is an optional dependency and failed compatibility check. Excluding it from installation.
    [4/5] Linking dependencies...
    warning " > @typescript-eslint/eslint-plugin@3.10.0" has unmet peer dependency "@typescript-eslint/parser@^3.0.0".
    warning " > marked-man@0.7.0" has incorrect peer dependency "marked@^0.7.0".
    [5/5] Building fresh packages...
    $ test -n "$NOCLIENT" || (cd client && yarn install --pure-lockfile)
    yarn install v1.22.5
    [1/4] Resolving packages...
    [2/4] Fetching packages...
    info fsevents@2.1.3: The platform "linux" is incompatible with this module.
    info "fsevents@2.1.3" is an optional dependency and failed compatibility check. Excluding it from installation.
    info fsevents@1.2.13: The platform "linux" is incompatible with this module.
    info "fsevents@1.2.13" is an optional dependency and failed compatibility check. Excluding it from installation.
    [3/4] Linking dependencies...
    warning " > file-loader@6.0.0" has unmet peer dependency "webpack@^4.0.0 || ^5.0.0".
    warning " > raw-loader@4.0.1" has unmet peer dependency "webpack@^4.0.0 || ^5.0.0".
    warning " > @ngx-i18nsupport/tooling@8.0.3" has incorrect peer dependency "@angular/common@^8.0.0".
    warning " > @ngx-i18nsupport/tooling@8.0.3" has incorrect peer dependency "@angular/core@^8.0.0".
    warning " > @ngx-loading-bar/http-client@5.1.0" has incorrect peer dependency "tslib@^1.10.0".
    warning " > @ngx-loading-bar/router@5.1.0" has incorrect peer dependency "tslib@^1.10.0".
    warning " > @ngx-meta/core@9.0.0" has incorrect peer dependency "@angular/core@>=9.0.0 <10.0.0".
    warning " > @ngx-meta/core@9.0.0" has incorrect peer dependency "@angular/platform-browser@>=9.0.0 <10.0.0".
    warning " > @ngx-meta/core@9.0.0" has incorrect peer dependency "@angular/platform-browser-dynamic@>=9.0.0 <10.0.0".
    warning " > @ngx-meta/core@9.0.0" has incorrect peer dependency "@angular/router@>=9.0.0 <10.0.0".
    warning " > @ngx-meta/core@9.0.0" has incorrect peer dependency "tslib@^1.10.0".
    warning " > angular2-hotkeys@2.2.0" has incorrect peer dependency "@angular/core@^5.2.0 || ^6.0.0 || ^7.0.0 || ^8.0.0 || ^9.0.0".
    warning " > angular2-hotkeys@2.2.0" has incorrect peer dependency "tslib@^1.10.0".
    warning " > bootstrap@4.5.2" has unmet peer dependency "jquery@1.9.1 - 3".
    warning " > bootstrap@4.5.2" has unmet peer dependency "popper.js@^1.16.1".
    warning " > css-loader@3.6.0" has unmet peer dependency "webpack@^4.0.0 || ^5.0.0".
    warning " > extract-text-webpack-plugin@4.0.0-beta.0" has unmet peer dependency "webpack@^3.0.0 || ^4.0.0".
    warning " > html-loader@1.2.1" has unmet peer dependency "webpack@^4.0.0 || ^5.0.0".
    warning " > html-webpack-plugin@4.3.0" has unmet peer dependency "webpack@>=4.0.0 < 6.0.0".
    warning " > linkifyjs@2.1.9" has unmet peer dependency "jquery@>= 1.11.0".
    warning " > linkifyjs@2.1.9" has unmet peer dependency "react@>= 0.14.0".
    warning " > linkifyjs@2.1.9" has unmet peer dependency "react-dom@>= 0.14.0".
    warning " > primeng@9.1.3" has incorrect peer dependency "@angular/core@^7.0.0 || ^8.0.0 || ^9.0.0".
    warning " > primeng@9.1.3" has incorrect peer dependency "@angular/common@^7.0.0 || ^8.0.0 || ^9.0.0".
    warning " > primeng@9.1.3" has incorrect peer dependency "@angular/forms@^7.0.0 || ^8.0.0 || ^9.0.0".
    warning " > sass-loader@8.0.2" has unmet peer dependency "webpack@^4.36.0 || ^5.0.0".
    warning "sass-resources-loader > @babel/cli@7.10.5" has unmet peer dependency "@babel/core@^7.0.0-0".
    warning "sass-resources-loader > babel-eslint@10.1.0" has unmet peer dependency "eslint@>= 4.12.1".
    warning " > terser-webpack-plugin@3.1.0" has unmet peer dependency "webpack@^4.0.0 || ^5.0.0".
    warning "tslint-config-standard > tslint-eslint-rules@5.4.0" has incorrect peer dependency "tslint@^5.0.0".
    warning " > webpack-cli@3.3.12" has unmet peer dependency "webpack@4.x.x".
    [4/4] Building fresh packages...
    $ npm rebuild node-sass
    Done in 37.28s.
    Done in 79.03s.
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment